Задать вопрос
0

Поиск пакетов содержащих необходимую библиотеку.

задан 2018-02-17 15:08:34 -0600

CooL_bobrui Gravatar

Приложение, которое я пытаюсь запустить требует библиотеку libcrypto.so.1.0.0, однако ни в интернете, ни dnf provides не нашли пакета содержащего это либу. Есть какой-то ресурс для поиска пакетов в Fedora 27 ? Раньше пользовался дебианом, у них удобный веб-сайт для поиска пакетов.

изменить изменить тег "пожаловаться" закрыть Объединить удалить

Комментарии

Есть какой-то ресурс для поиска пакетов в Fedora

https://apps.fedoraproject.org/packages

maxim Gravatarmaxim ( 2018-02-21 06:15:56 -0600 )изменить

2 Ответы

Сортировать по » старые новые больше голосов
0

отвечен 2018-02-19 02:31:57 -0600

Serguei Khvatov Gravatar

Библиотека libcrypto принадлежит пакету openssl-libs. Проблема в том, что в Fedora27 текущая версия 1.1, а она с 1.0 несовместима. Есть libcrypto.so.1.0.2m в пакете compat-openssl10

изменить "пожаловаться" удалить ссылка ещё
0

отвечен 2018-02-18 08:55:09 -0600

nkly Gravatar

Скорее всего это пакет libssh Нужно искать командой

dnf search libcrypto

Поиск пакетов происходит с помощью dnf. Что касается работы с пакетами - он может все. Где-то в инфраструктуре fedoraproject.org натыкался на сайт где можно получить информацию по любому пакету, но не помню его адрес.

изменить "пожаловаться" удалить ссылка ещё

Инструменты для обсуждения

1 подписчик

Статистика

Задан: 2018-02-17 15:08:34 -0600

Просмотрен: 198 раз

Последнее обновление: Feb 19 '18

похожие вопросы: