Pergunte aqui

Perfil de mseleng - atividade

2016-10-03 19:11:03 -0500 Medalha recebida  Pergunta popular (fonte)
2016-09-21 23:37:14 -0500 Medalha recebida  Pergunta famosa (fonte)
2016-09-21 23:37:14 -0500 Medalha recebida  Pergunta notável (fonte)
2016-08-02 13:01:25 -0500 Medalha recebida  Pergunta popular (fonte)
2016-07-21 18:32:59 -0500 Respondeu uma pergunta Cannot start X server on F24

The answer is even easier as I have finally found out on Ubuntu forums: I just needed to run optirun nvidia-settings -c :8 instead of just nvidia-settings to configure X. I think that's all and I can mark this as solved.

2016-07-20 15:46:18 -0500 Resposta comentada Cannot start X server on F24

So..removed nvidia and bumblebee, X running again. Thanks for advices.

2016-07-13 15:21:12 -0500 Resposta comentada Cannot start X server on F24

Can you, please suggest how to do so? (replace with nouveau), I mean getting rid of nvidia stuff? And yes, I am using bumblebee, mostly because of steam games. Moreover, it is just one day without Xfce and I am starting to feel terrible about gnome-shell memory consumption (2.1GB vs. ~750MB with Xfce)..working with IDEA or Android Studio is pretty pain as it (the Studio) consumes about 5GB. Anyway, why do I need to switch to PRIME?

2016-07-13 11:57:08 -0500 Pergunta comentada Cannot start X server on F24

@fabash http://pastebin.com/sCaps7a7 <-- here is the result. I am pretty sure that my card is supported, as I can clearly see it here under supported products~~>GeForce 600M series (GT635M)

2016-07-13 04:09:06 -0500 Pergunta comentada Cannot start X server on F24

@fabash sudo modprobe nvidia output the following:

modprobe: ERROR: could not insert 'nvidia': No such device

Probably really issue with the driver. Maybe I need to wait for some update and use gnome on wayland till then :(. I was thinking that maybe the selinux-policy update broke something, because I read earlier, when isntalling drivers that sometimes selinux prevents nvidia modules from loading.

2016-07-13 04:05:05 -0500 Pergunta comentada Cannot start X server on F24

@sideburns sddm was only preference thing, nothing important, it just looks better for me than the lightDM (had that also). Yes, when in gdm I cannot log into any other DM (Gnome/Xfce). I ran systemctl sddm status on when this occurred for the very first time and (I did not saved the output) there was something 'bout core dump. I don't think this is related to sddm anymore, because of unability to configure X through X -configure. Today I ran dnf update which updated Xorg, but nothing has changed yet.

2016-07-12 17:37:07 -0500 Medalha recebida  Pergunta boa (fonte)
2016-07-12 17:34:47 -0500 Medalha recebida  Pergunta notável (fonte)
2016-07-12 14:28:56 -0500 Perguntou Cannot start X server on F24

Hi, after my today's dnf update I can no longer start sddm nor the X.

I am not sure, whether it was caused by the update itself, because I cannot see any package, that could potentially brick it. (see this paste for info about updated packages). Moreover I also installed qt5-qtgraphicaleffects, but I don't think it could have caused the problem (it is already removed, but nothing has changed).

I am typing here, just because I was able to somehow start gdm and log into Gnome on Wayland (that's the only one that works); normally I use the Xfce.

Here is the most relevant /var/log/Xorg.0.log:

[   974.606] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   974.607] (II) xfree86: Adding drm device (/dev/dri/card0)
[   974.608] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[   974.610] (--) PCI:*(0:0:2:0) 8086:0166:17aa:3901 rev 9, Mem @ 0xd3400000/4194304, 0xe0000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/131072
[   974.610] (II) LoadModule: "glx"
[   974.610] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   974.613] (II) Module glx: vendor="X.Org Foundation"
[   974.613]    compiled for 1.18.3, module version = 1.0.0
[   974.613]    ABI class: X.Org Server Extension, version 9.0
[   974.613] (==) AIGLX enabled
[   974.613] (II) LoadModule: "nvidia"
[   974.614] (WW) Warning, couldn't open module nvidia
[   974.614] (II) UnloadModule: "nvidia"
[   974.614] (II) Unloading nvidia
[   974.614] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   974.614] (EE) No drivers available.
[   974.614] (EE) 
Fatal server error:
[   974.614] (EE) no screens found(EE) 
[   974.614] (EE) 
Please consult the Fedora Project support 
     at http://wiki.x.org
 for help. 
[   974.614] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   974.614] (EE)

Here I need to say that until today everything worked perfectly (I do have nvidia drivers through bumblebee and they did not do any problems till now)

When I run sudo nvidia-xconfig it finishes successfully and here's the xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.27  (buildmeister@swio-display-x64-rhel04-12)  Thu Jun  9 19:24:36 PDT 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I have absolutely no clue about what is going on ... (more)

2016-07-12 14:06:10 -0500 Respondeu uma pergunta Bumblebee not working

So this got fixed by the latest kernel update and bumblebee's update to the newest version following.

2016-07-04 14:40:04 -0500 Medalha recebida  Pergunta popular (fonte)
2016-07-04 05:05:20 -0500 Medalha recebida  Organizador (fonte)
2016-07-01 07:33:14 -0500 Medalha recebida  Pergunta boa (fonte)
2016-06-29 18:09:32 -0500 Perguntou Bumblebee not working

Hi, I have installed Bumblebee, following the instructions on the official page.

Then I wanted to check whether it is correctly installed and running, i ran optirun glxgears -info | grep GL_VENDOR and I got the following output

[ 1862.301805] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1862.301871] [ERROR]Could not connect to bumblebee daemon - is it running?

When I tried to run the bumblebee daemon manually, using bumblebeed, I got:

modprobe: FATAL: Module bbswitch not found in directory /lib/modules/4.5.2-302.fc24.x86_64
[ 1934.657769] [ERROR]Module bbswitch could not be loaded (timeout?)
[ 1934.657797] [WARN]No switching method available. The dedicated card will always be on.
[ 1934.659638] [ERROR]Module 'nvidia' is not found

That looks weird, cuz I am pretty sure I got bbswitch installed and also got the nvidia GPU. To move forward I ran bumblebee-nvidia --debug which gave me the following output:

ERROR: Unable to find the kernel source tree for the currently running kernel. 
   Please make sure you have installed the kernel source files for your
   kernel and that they are properly configured; on Red Hat Linux systems,
   for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
   installed.  If you know the correct kernel source files are installed,
   you may specify the kernel source path with the '--kernel-source-path'
   command line option.

Then it suggests to look into /var/log/nvidia-installer.log, but there is only this information also.

I reviewed the versions of instaled bumblebee packages and I found out that they were for kernel 4.5.7-300, but running uname -r says, that I am only running kernel 4.5.2.302. However, dnf update does not update kernel (maybe it did, later and I didn't realize?) and also grub is saying that only 4.5.2-302 kernel is installed, alongside with Win10.

Could you guys help? I was googling a lot recently, but I didn't find anything useful.

Thank you

2016-06-29 15:35:14 -0500 Medalha recebida  Estudante (fonte)
2016-06-28 14:29:33 -0500 Pergunta comentada Rpmfusion repositories

@hhlp thanks for the answer, but I noticed @sergiomb 's answer earlier and it works also. But still, thanks for the quick response

2016-06-28 14:29:21 -0500 Resposta comentada Rpmfusion repositories

thanks man, this works pretty fine!

2016-06-28 14:23:04 -0500 Medalha recebida  Acadêmico (fonte)
2016-06-28 09:52:26 -0500 Perguntou Rpmfusion repositories

Hi guys, I wanted to install nVidia drivers to my machine, running F24. I found this 'tutorial' which seems to be legit, but I am gettinginto troubles as it says, that it (dnf) was unable to find the desired package (akmod-nvidia).

I am pretty sure that I have rpmfusion repositories installed and enabled (free and non-free). When I look on the rpmfusion web, especially to the list of packages, here, I can see, that there are many packages available in the repo.

When I run dnf repolist | grep rpmfusion I get the following output:

rpmfusion-free             RPM Fusion for Fedora 24 - Free                     0
rpmfusion-free-updates     RPM Fusion for Fedora 24 - Free - Updates           8
rpmfusion-nonfree          RPM Fusion for Fedora 24 - Nonfree                  0
rpmfusion-nonfree-updates  RPM Fusion for Fedora 24 - Nonfree - Updates        0

I think that the status number means the number of packages that are available in the repo. Similarly, when I run dnf list available | grep rpmfusion I am getting only 8 entries.

When I run sudo dnf update it says, that there is nothing to do, same when used --refresh

Can you please suggest me any possible solution?

Thanks in advance