Pergunte aqui

Perfil de madchem - atividade

2018-05-22 12:56:45 -0500 Medalha recebida  Pergunta notável (fonte)
2018-05-18 03:27:59 -0500 Medalha recebida  Pergunta popular (fonte)
2018-03-07 12:50:21 -0500 Medalha recebida  Pergunta famosa (fonte)
2018-03-07 12:50:21 -0500 Medalha recebida  Pergunta notável (fonte)
2018-03-07 12:50:21 -0500 Medalha recebida  Pergunta popular (fonte)
2017-05-31 14:32:29 -0500 Pergunta comentada Hawaii on Xorg

Got it! Thank you.

2017-05-31 08:52:20 -0500 Medalha recebida  Estudante (fonte)
2017-05-31 08:32:35 -0500 Perguntou Hawaii on Xorg

For some reason I have removed Gnome-desktop and installed Hawaii desktop using dnf groupinstall "Hawaii". It includes xorg-x11-drv-evdev as described here. But I have encountered a problem.

SDDM menu have entries "Openbox" (as Hawaii's WM, I guess) and "Hawaii (Wayland)". So Hawaii (Wayland) doesn't start because my driver is Nvidia proprietary. When I try to enter the 3 runlevel and start Hawaii on Xorg using startx /usr/bin/hawaii nothing happen. There are no EE's in /var/log/Xorg.0.log. And I have uncommented Xorg sections in /etc/sddm.conf. No results.

I am so confused... Is it any way to start Hawaii using Xorg, not Wayland? Or should I remove my proprietary Nvidia driver first?

2017-04-03 05:22:55 -0500 Respondeu uma pergunta How can I create a folder containing multiple launchers on the left panel?

Maybe, you want to try cairo-dock application? Or, you may group your IDEs into one folder using this wiki-page: https://wiki.gnome.org/HowDoI/AppFolders

2017-04-03 05:16:27 -0500 Pergunta comentada Desktop manager won't start after kernel update to 4.10

Did you try to boot without graphics and start DE via systemctl isolate graphical.target?

2017-04-01 06:28:58 -0500 Pergunta comentada how to add the repository of packages in the fedora os which is installed on virtual box?

What is the meaning of this? You just installed fedora to VM and you can't install any package? You have to check your VM internet connection.

2017-03-23 10:13:41 -0500 Pergunta comentada WiFi keeps dropping after several minutes

Try to read man iwconfig in your system. Wifi has timeout to go down.

2017-03-23 05:19:05 -0500 Pergunta comentada Newish Nvidia Driver

Downloading and installing nvidia driver every kernel update is not the job you want. Install driver from repo like rpmfusion or negativo17 is much better.

2017-03-23 05:13:37 -0500 Respondeu uma pergunta How to copy those messages that appear on top of the screen??

Try to launch ABRT application. If you use GNOME-shell, so it it gnome-abrt. You also may send bug report to the RedHat Bugzilla if you have rhbz account.

2017-03-23 05:07:01 -0500 Medalha recebida  Palpiteiro
2017-03-23 05:07:01 -0500 Pergunta comentada Do I installed a fake Phatch?

I think it's a bug in program. Phatch not work for me. Every package in repo has the key, so you cannot install 'fake' package.

2017-03-23 01:59:42 -0500 Medalha recebida  Resposta boa (fonte)
2017-03-23 00:29:10 -0500 Medalha recebida  Resposta legal (fonte)
2017-03-22 17:19:12 -0500 Medalha recebida  Autodidata (fonte)
2017-03-22 16:26:35 -0500 Respondeu uma pergunta KDE is ugly turbid

I just disabled windows scaling in settings > monitor > effects and it works! The problem is solved.

2017-03-22 05:47:07 -0500 Perguntou KDE is ugly turbid

I just installed KDE5 group on my Gnome-workstation (because GNOME is now laggy, after last update) and encountered the big problem: all windows are turbid. I cannot read any word. It looks like zipped image. It is an option in kwinrc Backend=openGL but it doesn't fix the problem. Sorry for my english. Open the link and look what does I mean. And sorry for provocative question's name :p https://www.dropbox.com/s/q9pfht494zq...

2017-03-20 10:21:19 -0500 Resposta comentada Cannot Login To GNOME (X-Wayland) at Greeter '25

Is your dbus.service running? systemctl status dbus.service It looks like you have installed Fedora with damaged ISO-file or so...

2017-03-20 03:00:43 -0500 Pergunta comentada Cannot Login To GNOME (X-Wayland) at Greeter '25

Do you have any proprietary drivers installed? Try to hit ctrl + alt + f4 as you will see the greeter. Login as user and examine your Xorg log file: cat /var/log/Xorg.0.log | grep EE

2017-03-14 06:26:38 -0500 Respondeu uma pergunta Savely remove nvidia card

Try to boot your computer. As you will see GRUB2 menu - hit 'e' button and find word 'linux16'. You should add symbol '3' to this line, like this:

linux16 vmlinuz=... initrd=... 3

then hit ctrl+x and wait for login screen. You should boot into non-graphics mode. Login with your account name and password. Delete Nvidia proprietary driver with:

sudo dnf remove \*nvidia\*

and reboot.

2017-03-14 06:17:41 -0500 Medalha recebida  Torcedor (fonte)
2017-03-13 09:45:15 -0500 Medalha recebida  Professor (fonte)
2017-03-12 06:28:45 -0500 Respondeu uma pergunta MP3 file won't open even after installing codec's (Fedora 25)

I recommend you to install VLC player from RPMFusion-free:

sudo dnf install vlc

If you have installed all codecs and VLC doesn't read the MPEG format, then add this line to your /etc/ld.so.conf file:

/usr/lib64

then type

sudo ldconfig
2017-03-11 14:33:17 -0500 Resposta comentada reinstall Fedora 25 Workstation without fresh install

I think you could do it more tricky: sudo dnf --allowerasing history undo last

2017-03-11 14:25:45 -0500 Pergunta comentada Trouble connecting to wifi via terminal and app.

Firstly you have to choose the device with nmcli:

nmcli radio wifi on
nmcli device wifi scan
nmcli device wifi connect (your wifi name)
2017-03-11 14:17:54 -0500 Pergunta comentada Error in OpenBabel package

https://www.dropbox.com/s/6cfqc4uzd8w...

This is NWChem output file. Try to install openbabel package and convert this file with

babel -inwo naoh1.out -oxyz
2017-03-07 06:02:18 -0500 Perguntou Error in OpenBabel package

As I updated from FC22 to FC24, it is the same error in OpenBabel package. Till FC25 that error is present. I tried to install openbabel package from repos and compile it by myself. The results are the same: when I want to convert NWChem output file into any other format, I recieve this error:

*** Error in `babel': free(): invalid pointer: 0x00007f1852c86330 ***
======= Backtrace: =========
/usr/lib64/libc.so.6(+0x791fb)[0x7f18672ac1fb]
/usr/lib64/libc.so.6(+0x8288a)[0x7f18672b588a]
/usr/lib64/libc.so.6(cfree+0x4c)[0x7f18672b92bc]
/usr/local/lib/openbabel/2.4.1/nwchemformat.so(_ZN9OpenBabel18NWChemOutputFormat15ReadCoordinatesEPSiPNS_5OBMolE+0x1ff)[0x7f1852a7d66f]
/usr/local/lib/openbabel/2.4.1/nwchemformat.so(_ZN9OpenBabel18NWChemOutputFormat12ReadMoleculeEPNS_6OBBaseEPNS_12OBConversionE+0x1ba)[0x7f1852a7f1ea]
/usr/local/lib/libopenbabel.so.5(_ZN9OpenBabel16OBMoleculeFormat18ReadChemObjectImplEPNS_12OBConversionEPNS_8OBFormatE+0x10ed)[0x7f1866f6c57d]
/usr/local/lib/libopenbabel.so.5(_ZN9OpenBabel12OBConversion7ConvertEv+0x1d5)[0x7f1866f02005]
/usr/local/lib/libopenbabel.so.5(_ZN9OpenBabel12OBConversion7ConvertEPSiPSo+0xa9)[0x7f1866f09709]
/usr/local/lib/libopenbabel.so.5(_ZN9OpenBabel12OBConversion11FullConvertERSt6vectorINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEESaIS7_EERS7_SA_+0x197d)[0x7f1866f0b18d]
babel(main+0xabb)[0x402d4b]
/usr/lib64/libc.so.6(__libc_start_main+0xf1)[0x7f1867253401]
babel(_start+0x2a)[0x4033ca]

On CentOS 7 and on Arch Linux all is good. So I guess it is fedora problem. You can try it out by installing openbabel package and using nwchem output file with the command:

babel -inwo file.nwo -oxyz
2016-12-28 05:39:02 -0500 Medalha recebida  Pergunta popular (fonte)
2016-12-23 10:11:54 -0500 Respondeu uma pergunta Fedora 25 nvidia

Попробуйте либо скачать с сайта nvidia и установить вручную, либо используйте другие репозитории.

Кажется, negativo17 - хороший репозиторий с несвободными компонентами.

P.S.: ссылок не даю, использование несвободных компонентов не пропагандирую, правила форума не нарушаю, да и вообще тих и мил.

2016-12-23 10:03:19 -0500 Medalha recebida  Editor (fonte)
2016-12-23 10:00:23 -0500 Respondeu uma pergunta Fedora 25. Зависает при первоначальной загрузке с флешки (не могу дойти до начала установки).

Очень похоже на глюк GDM.

Попробуйте загрузиться с флешки, увидите окно приветствия и предложение установить дистрибутив (install fedora, test this media..., troubleshooting). Сразу нажимайте кнопку tab. Внизу появятся белые буквы примерного содержания:

vmlinuz inintrd=initrd.img

В самом конце (после слова quiet) введите цифру 3 и нажмите enter. Загрузка должна закончиться "моргающим курсором":

localhost login: _

Введите с клавиатуры liveuser. Должна появиться командная строка пользователя. Введите команду startx и установите систему.

Альтернативный вариант - скачать образ netinstall для установки системы по сети.

Если это действительно Display Manager - то вам придётся после установки его сменить.

2016-11-06 07:17:26 -0500 Medalha recebida  Acadêmico (fonte)
2016-11-04 13:08:56 -0500 Perguntou Which package provides pactl command

In my FC24 there is no pactl command. If I use: pactl or /usr/bin/pactl the shell returns

command not found

dnf provides '\*pactl\*' says no matches found. Is it any package in Fedora with the pactl command or does it have analogous command?

2016-09-27 12:36:20 -0500 Perguntou How to remove systemd

Hi! I encountered problem with Avogadro program. When I open NWChem output files it uses OpenBabel for coordinates transform. But OpenBabel is broken: I receive SegFault.

So. I tried to install older version of openbabel that working:

# dnf install avogadro --installroot=/opt/gcc4 --releasever=21 --nogpgcheck

But it doesn't help:

[madchem@desktop ~]$ LD_LIBRARY_PATH=/opt/gcc4/lib64 /opt/gcc4/bin/avogadro
Segmentation fault (core dumped)

So... Now I need to remove installed packages from /opt/gcc4 but dnf says:

The operation would result in removing the following protected packages: systemd.

Is it OK if I delete the whole /opt/gcc4 directory?

# rm -rf /opt/gcc4

Or it will broke dnf?

2016-07-09 17:14:58 -0500 Respondeu uma pergunta VLC on FC24

I've found 'bad' solution.

It seems that vlc could not find libvpx.so.2 library. So, when I run

LD_LIBRARY_PATH=/usr/lib64 vlc myvideo.mp4

it works. Is there any way to link /usr/lib64 directory for vlc?

2016-07-09 14:12:42 -0500 Resposta comentada VLC on FC24

No effect. I can't even watch my Blender video. It's no MJPG and MKV codecs.

2016-07-09 10:54:06 -0500 Perguntou VLC on FC24

Hi folks!

Its problem with mp4, mov, flv and so on video formats. I've installed VLC from RPMfusion, gstreamer and x264, x265. But no effect. Every time VLC prints the message

VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))

Installed programs, libs and codecs:

[madchem@desktop ~]$ dnf list installed ffmpeg gstreamer{,1}\* x26\* vlc\* | awk '{ print $1}'
ffmpeg.x86_64
gstreamer.x86_64
gstreamer-devel-docs.noarch
gstreamer-ffmpeg.x86_64
gstreamer-plugin-crystalhd.x86_64
gstreamer-plugins-bad.x86_64
gstreamer-plugins-bad-free.x86_64
gstreamer-plugins-bad-free-extras.x86_64
gstreamer-plugins-bad-nonfree.x86_64
gstreamer-plugins-base.x86_64
gstreamer-plugins-ugly.x86_64
gstreamer-tools.x86_64
gstreamer1.i686
gstreamer1.i686
gstreamer1.x86_64
gstreamer1.x86_64
gstreamer1-devel.x86_64
gstreamer1-devel.x86_64
gstreamer1-devel-docs.noarch
gstreamer1-devel-docs.noarch
gstreamer1-libav.x86_64
gstreamer1-libav.x86_64
gstreamer1-libav-devel-docs.noarch
gstreamer1-libav-devel-docs.noarch
gstreamer1-plugins-bad-free.x86_64
gstreamer1-plugins-bad-free.x86_64
gstreamer1-plugins-bad-free-devel.x86_64
gstreamer1-plugins-bad-free-devel.x86_64
gstreamer1-plugins-bad-free-extras.x86_64
gstreamer1-plugins-bad-free-extras.x86_64
gstreamer1-plugins-bad-free-fluidsynth.x86_64
gstreamer1-plugins-bad-free-fluidsynth.x86_64
gstreamer1-plugins-bad-freeworld.x86_64
gstreamer1-plugins-bad-freeworld.x86_64
gstreamer1-plugins-base.i686
gstreamer1-plugins-base.i686
gstreamer1-plugins-base.x86_64
gstreamer1-plugins-base.x86_64
gstreamer1-plugins-base-devel.x86_64
gstreamer1-plugins-base-devel.x86_64
gstreamer1-plugins-base-devel-docs.noarch
gstreamer1-plugins-base-devel-docs.noarch
gstreamer1-plugins-base-tools.x86_64
gstreamer1-plugins-base-tools.x86_64
gstreamer1-plugins-entrans.x86_64
gstreamer1-plugins-entrans.x86_64
gstreamer1-plugins-entrans-docs.noarch
gstreamer1-plugins-entrans-docs.noarch
gstreamer1-plugins-fc.x86_64
gstreamer1-plugins-fc.x86_64
gstreamer1-plugins-good.x86_64
gstreamer1-plugins-good.x86_64
gstreamer1-plugins-good-extras.x86_64
gstreamer1-plugins-good-extras.x86_64
gstreamer1-plugins-ugly.x86_64
gstreamer1-plugins-ugly.x86_64
gstreamer1-plugins-ugly-devel-docs.noarch
gstreamer1-plugins-ugly-devel-docs.noarch
gstreamer1-rtsp-server.x86_64
gstreamer1-rtsp-server.x86_64
gstreamer1-rtsp-server-devel.x86_64
gstreamer1-rtsp-server-devel.x86_64
gstreamer1-rtsp-server-devel-docs.noarch
gstreamer1-rtsp-server-devel-docs.noarch
gstreamer1-vaapi.x86_64
gstreamer1-vaapi.x86_64
gstreamer1-vaapi-devel-docs.noarch
gstreamer1-vaapi-devel-docs.noarch
vlc.x86_64
vlc-core.x86_64
vlc-extras.x86_64
x264.x86_64
x264-devel.x86_64
x264-libs.x86_64
x265.x86_64
x265-devel.x86_64
x265-libs.x86_64

I have no idea what is wrong.

2016-07-02 17:20:30 -0500 Pergunta comentada Can't run Minecraft using command line

Try download Java as RPM and install it. Then enable propriatary Java using sudo alternatives --install /usr/bin/java java /usr/java/latest/bin/java 1 Enjoy minecraft with java $LAUNCHER where $LAUNCHER is your .jar file. P.S.: openJDK is not so good for minecraft.

2016-07-02 16:00:47 -0500 Pergunta comentada libssl, libcrypto in fedora24/gnome

Try locate libssl libcrypto. I've same problem with Steam's game Magicka 2.

2016-06-27 09:51:04 -0500 Pergunta comentada gnome-shell/X crashes

Same problem. Nvidia drivers 367 and 352 are tested.