Pergunte aqui

Perfil de ceres2009 - atividade

2019-04-08 00:26:45 -0500 Medalha recebida  Pergunta popular (fonte)
2018-09-05 05:42:23 -0500 Medalha recebida  Pergunta famosa (fonte)
2018-09-05 05:42:23 -0500 Medalha recebida  Pergunta notável (fonte)
2018-09-05 05:42:23 -0500 Medalha recebida  Pergunta popular (fonte)
2018-08-20 01:35:58 -0500 Medalha recebida  Pergunta boa (fonte)
2018-01-25 02:54:37 -0500 Perguntou mariadb wont start after dnf update

i have a mariadb for owncloud installed on a F26 server. After yesterdays dnf update mariadb wont start with following log:

mariadb.service: Failed with result 'protocol'. Database MariaDB is probably initialized in /var/lib/mysql already, nothing is done.

Jan 25 09:28:27 oc.server.com systemd[1]: Starting MariaDB 10.1 database server...
Jan 25 09:28:27 oc.server.com mysql-check-socket[3547]: Socket file /var/lib/mysql/mysql.sock exists.
Jan 25 09:28:27 oc.server.com mysql-check-socket[3547]: No process is using /var/lib/mysql/mysql.sock, which means it is a garbage, so it will be removed automatically.
Jan 25 09:28:27 oc.server.com mysql-prepare-db-dir[3570]: Database MariaDB is probably initialized in /var/lib/mysql already, nothing is done.
Jan 25 09:28:27 oc.server.com mysql-prepare-db-dir[3570]: If this is not the case, make sure the /var/lib/mysql is empty before running mysql-prepare-db-dir.
Jan 25 09:28:28 oc.server.com mysqld[3605]: 2018-01-25  9:28:28 139930537759936 [Note] /usr/libexec/mysqld (mysqld 10.1.30-MariaDB) starting as process 3605 ...
Jan 25 09:28:28 oc.server.com systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Jan 25 09:28:28 oc.server.com systemd[1]: Failed to start MariaDB 10.1 database server.
Jan 25 09:28:28 oc.server.com systemd[1]: mariadb.service: Unit entered failed state.
Jan 25 09:28:28 oc.server.com systemd[1]: mariadb.service: Failed with result 'exit-code'.

From the error messages it looks exactly like https://bugzilla.redhat.com/show_bug.... but that bug is for F27 only.

I tried backing up /var/lib/mysql and emptying it => same error

I tried changing SELinux, as suggested in the comments.=> same error

I tried reverting the update with dnf => this fails because it couldn't find a package?!

No package GeoIP-GeoLite-data-0:2017.10-1.fc26.noarch available.
Error: An operation cannot be undone

I tried reinstalling mariadb => same error

I'm out of ideas. Anybody has an hint how to get it running again?

2018-01-09 14:23:33 -0500 Medalha recebida  Pergunta boa (fonte)
2018-01-09 14:23:04 -0500 Marcada como a melhor resposta How do I install the Cinnamon Desktop on Fedora Workstation?

I set up my laptop with f25 64-bit default Workstation. Now I want to install the Cinnamon desktop group, which fails with:

Environment 'Cinnamon Desktop' is already installed, skipping.

But despite that message, it is not selectable in GDM. And, when i try to remove it with:

sudo dnf group remove cinnamon-desktop-environment
Last metadata expiration check: 0:13:30 ago on Sat Jan 14 18:40:58 2017. 
Dependencies resolved.
Error: The operation would result in removing the following protected packages: dnf, systemd-udev, systemd.

Is there a possibility to resolve the issue and install Cinnamon without using the Cinnamon Spin on Fedora 25? If not - would it be possible to install from the Spin?

2017-12-27 08:49:37 -0500 Resposta comentada English for UI - local regional settings for date, sorting etc.

Hi, sry for delay i tried today.

> sudo localectl set-locale LC_ALL=de_DE.UTF-8
Failed to issue method call: Invalid Locale data.

seems to fail to set this specific variable. I'm pretty sure that's the correct value.. edit: after a locale -a i got de_DE.utf8 as a possibility, but that string fails with the same message.

2017-12-21 02:54:22 -0500 Pergunta comentada I have a laptop running fedora 27, whenever I close it I have to hard restart it otherwise the screen just stays black

you could try to <ctrl>+<alt>+<f6> (depending on your laptop maybe + <fn> Key) to switch to console and <ctrl>+<alt>+<f1> (+<fn>) to switch back to graphical frontend. Not a solution, but it helped me as a workaround until driver was fixed.

To find the cause of that issue you should look in your log file with

journalctl -xe

if and when you get an event "lid closed" or "target: Sleep" from systemd. And look for errors or warnings around that event.

2017-12-20 08:27:38 -0500 Resposta comentada English for UI - local regional settings for date, sorting etc.

yes, that would be my goal (VT + X11).
I use german keyboard layout.

2017-12-20 03:13:14 -0500 Perguntou English for UI - local regional settings for date, sorting etc.

Hi,

i'm trying to achive the following setup:

  1. english as a language setting for the whole UI.
  2. german for all other locale settings like Date format, week start, currency, number.

I set this in KDE settings, but all formats are apparently en_US. How and where would i persistently set this settings? Here's my locale output:

 > locale
LANG=en_DE.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

heres the /etc/locale.conf ...

LANG=en_US.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_PAPER=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8

Anybody has an hint, why actual local settings vary from /etc/locale.conf

2017-12-07 03:52:12 -0500 Respondeu uma pergunta Problem reboot to upgrade from 26 to 27

Hi, finally for me the comment 50 from Martin Uding's Bug Report solved the issue. https://bugzilla.redhat.com/show_bug.cgi?id=1492036#c50

2017-11-30 06:17:45 -0500 Perguntou How to change KDE default window position with dual display setup

Hi, i'm using F26 with KDE 5.10. And i use two displays at work. A newly openend window is always openend overlapping both displays.

I already defined actions for some programs to open on display 1 or 2, with an initial position. But i'm asking myself if i can set a default for all new windows.

2017-11-29 08:05:14 -0500 Pergunta comentada Fedora F26 to F27 update issues

no, i have another issue ;-) You could try looking if one of the python versions is coming from a repo. And than disable that repo - do the upgrade - and enable it again.

2017-11-27 02:11:35 -0500 Resposta comentada Cache for “updates” cannot be synchronized in f26 to f27 offline upgrade

again, didn't work for me.

2017-11-27 02:10:04 -0500 Resposta comentada Problem reboot to upgrade from 26 to 27

didn't work for me, sadly. Still the OPs behaviour.

2017-09-06 09:20:02 -0500 Medalha recebida  Pergunta popular (fonte)
2017-08-23 10:18:36 -0500 Medalha recebida  Pergunta notável (fonte)
2017-08-23 10:18:36 -0500 Medalha recebida  Pergunta popular (fonte)
2017-07-13 09:31:22 -0500 Medalha recebida  Pergunta famosa (fonte)
2017-06-12 05:25:11 -0500 Medalha recebida  Pergunta famosa (fonte)
2017-05-29 04:51:21 -0500 Pergunta comentada Virtualbox and KVM/QEMU parallel use possible

thanks florian, then i will try a "migration" to virtualbox. If you convert your comment to answer it can mark it correct.

2017-05-24 11:17:38 -0500 Resposta comentada Virtualbox and KVM/QEMU parallel use possible

ok, i will check that the next time, but i can get loads like now: 1,00 1,17 1,49 when just webbrowsing in fedora and windows machine idling with office. And no svchost using cpu time in the windows task manager.

2017-05-24 11:15:22 -0500 Pergunta comentada Virtualbox and KVM/QEMU parallel use possible

thanks and yes that's what i meant running both at the same time. Does it have a negative effect to have both installed at the same time?

2017-05-24 03:26:53 -0500 Perguntou Virtualbox and KVM/QEMU parallel use possible

Hi, i'm facing some performance issues with a KVM/QEMU Setup with Windows 7 guest. When Win7 is idling at 6% kvm takes in average 120% load. So i was wondering to give Virtualbox a try. Is it possible/sensible to do that in parallel?

2017-04-29 07:44:25 -0500 Medalha recebida  Pergunta notável (fonte)
2017-04-16 06:25:41 -0500 Medalha recebida  Pergunta notável (fonte)
2017-04-16 06:25:41 -0500 Medalha recebida  Pergunta popular (fonte)
2017-04-06 02:17:27 -0500 Resposta comentada Spotify copy URI not available anymore

Hi Sergiomb, i'm not sure if i understand you entirely. ATM i do not have lpf- installed. Just:

libspotify.x86_64                     12.1.51-4.fc24               @@commandline
libspotify-devel.x86_64               12.1.51-4.fc24               @@commandline
openssl-spotify.x86_64                1.0.0-5.fc25                 @unitedrpms  
spotify-client.noarch                 1.0.44.100.ga60c0ce1-2.fc25  @unitedrpms

Does this mean it is an EULA issue and i need to install it via lpf?

2017-04-05 04:46:20 -0500 Medalha recebida  Pergunta notável (fonte)
2017-04-05 04:46:20 -0500 Medalha recebida  Pergunta famosa (fonte)
2017-04-03 16:09:25 -0500 Resposta comentada Spotify copy URI not available anymore

tried re-installing and using UnitedRPMs instead. Same issue.

2017-04-03 16:08:48 -0500 Pergunta comentada Spotify copy URI not available anymore

sorry, for late reply, just removed spotify from negativo repo and installed spotify-client from unitedRpms. Same behaviour no Copy URI here. Everything else is in the menu.. Used spotify-reset and started again - still no joy.

[edit: converted to answer, but only found a workaround for copying exactly one URI via the "..." Menu -> Share -> URI

still missing one from the context menu. ]

2017-03-29 07:04:35 -0500 Perguntou Spotify copy URI not available anymore

Hi, anyone an idea on this. I'm using spotify from negativo17 repository. Since a few days "Copy URI" is not available in any context menu anymore. According to spotify support site it should still be there.

Anybody here with the same issue?

2017-03-28 06:26:43 -0500 Medalha recebida  Pergunta notável (fonte)
2017-03-28 06:26:43 -0500 Medalha recebida  Pergunta popular (fonte)
2017-02-20 09:31:02 -0500 Resposta comentada Why nm-connection-editor can't be reached from GUI?

in my case it's cinnamon. There it is named "Network Connections" and is the last point in the menu, when you left click on the network symbol.

2017-02-16 12:00:13 -0500 Pergunta comentada How to enable automatic screen resolution adaption on KVM guest OS?

Hi, i can only share information for ubuntu, there i have a package installed named: spice-vdagent. And are using QXL as the kernel-module for graphics card.

Und Windows Guest i had to use QXL and installed all the drivers from virtio CD Image.

2017-02-16 06:31:31 -0500 Perguntou How to prevent an USB devices from being redirected to a KVM VM?

Hi,

i have a Windows7 KVM running on my F25 laptop. I use ethernet, wifi and LTE in Linux to provide NATed Network for the VM. For some reasons, most often after waking up the laptop from sleep, the LTE Card is gone in Linux and seems to be redirected to the VM.

Is there any way to prevent KVM/QEMU from redirecting a specific device, only? So LTE Card never redirect, USB thumb drive etc. always redirect.

2017-02-16 04:53:26 -0500 Respondeu uma pergunta Sierra Wireless EM7345 4G LTE stops working

Hi,

to answer my own question and later raise a new one ;-) The issue seems to be related to a virtual machine running in KVM, that is getting the LTE Cards USB redirected. I noticed, that when i shut down this VM than the LTE Card appears again.

2017-02-11 04:56:45 -0500 Medalha recebida  Pergunta popular (fonte)
2017-02-06 00:38:33 -0500 Pergunta comentada wifi is not working in fedora 25

try to find the exact name of the wireless card. try to scan dmesg for errors at boot time. Some wireless cards have both open source and closed source drivers.