Pergunte aqui
0

Internet para de funcionar

perguntadas 2017-05-09 19:54:24 -0500

imagem do gravatar de lucasteixeira

Saudações!

Solicito a ajuda de vocês neste caso. Fiz uma instalação do Fedora 25. Já tem uma semana de uso normal, atualizações, instalações de pacotes, navegação na internet tudo ok, com performance normal.

O problema é que, "do nada", eventualmente percebo que estou sem internet, tanto via navegador quando via terminal.

Basta desativar e reativar o adaptador de rede (neste caso conexão cabeada, Realtek r8169) e tudo volta ao normal.

Não é constante, acontece esporadicamente, mas foi algo que observei nesses primeiros dias de uso.

O que infelizmente não consegui identificar foi alguma causa para o problema.

Alguém já teve esse problema e/ou saberia como me ajudar?

Desde já agradeço a atenção de todos. Um abraço!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

0

respondidas 2017-05-11 08:15:21 -0500

imagem do gravatar de danniel

tive um problema parecido comigo e era problema com meu DHCP faz o seguinte , deixa ip Fixo na maquina e verifica se vai ocorrer o mesmo problema

editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado pela dica Danniel!

Realmente faz sentido e eu não havia pensado nisso.

Ontem aconteceu novamente e fiz o teste colocando o ip fixo, mas não usei muito mais o computador. Vou acompanhar os próximos dias e dou um feedback mais consistente.

Se for isso mesmo, dou uma "geral" no meu modem/roteador (já não estava satisfeito com o desempenho dele, realmente pode estar com problemas).

Mais uma vez obrigado! Um abraço!

imagem do gravatar de lucasteixeiralucasteixeira ( 2017-05-12 09:48:12 -0500 )editar

Prezado Daniel,

Realmente era isso, desculpe a demora para dar o retorno. Mas ao configurar o IP fixo o problema deixou de ocorrer. Realizei a substiuição do modem/roteador e agora também está tudo certo com o IP via DHCP.

Muito obrigado pela ajuda! Um abraço!

imagem do gravatar de lucasteixeiralucasteixeira ( 2017-05-18 18:09:50 -0500 )editar

Show , que bom que resolveu

imagem do gravatar de dannieldanniel ( 2017-06-01 09:19:10 -0500 )editar
0

respondidas 2017-05-15 06:24:48 -0500

Prezados,

solicito algum apoio para descobrir esse mistério que relato abaixo:

tenho um servidor linux Fedora 23 rodando apenas Squid e um Firewall (DNF) com Iptables;

tenho um roteador do provedor de internet com dois IPs públicos e FIXOS, vou chamar aqui de IP-1 que uso para a rede cabeada e IP-2 para a rede wifi;

tenho duas placas de rede (enp0s7 com IP FIXO da rede interna - 192.168.X.X) e (enp1s5 com IP FIXO da rede Internet- uso aqui o IP-1);

tenho um roteador Wifi que usa o outro IP público, no caso IP-2 (as redes cabeada e Wifi não se comunicam pois elas estão ligadas apenas via roteador do provedor)

O problema:

Com certa frequência eu perco a conectividade com a rede internet APENAS pelo servidor Linux Fedora. Então faço um acesso ao servidor e tento pingar o Gateway do provedor e não tenho sucesso, também tento pingar os servidores DNS prim e slave e também sem sucesso. Já pela rede Wifi consigo realizar esses testes de pingar o GW e o DNS normalmente e com sucesso.

O que tento fazer para resolver o problema do servidor linux:

1) desligo e ligo a placa de rede (ifdow enp1s5 e depois ifup enp1s5) - não resolve 2) reinicio o serviço networkin (service network restart) - não resolve 3) reinicio o serviço do firewall (service firewall restart) - não resolve 4) desligo o firewall (service firewall direct) - não resolve

Como resolvo:

executo o comando reboot no servidor!

Não dá pra fazer isso sempre! tem como eu resolver isso de forma definitiva ??

Obrigado

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2017-05-18 18:26:50 -0500

imagem do gravatar de lucasteixeira

Olá Marcelo,

Realmente seu problema parece estranho.

Tenho uma sugestão que pode ser mais estranha ainda, mas se você está sem opções, talvez não custe tentar.

Já pensou em substituir as configurações de um placa pela outra, ou seja, colocar o IP 1 na placa 2 e o IP 2 na placa 1?

Pode parecer bobo, mas com essa situação você talvez seja possível identificar se é um problema da placa, físico por exemplo.

Caso o problema "passe" para a outra placa junto com a configuração do IP, talvez esteja relacionado com algo que interaja com esta interface, um computador cliente com algum problema, ou algum scanner de rede.

Enfim, não é uma resposta técnica, mas pode ser uma maneira de descobrir o que pode estar acontecendo.

OBS.: Não sou moderador, e também sou novo aqui no fórum, mas fiquei meio perdido para responder diretamente a sua pergunta, sem estar atrelado à pergunta original. Talvez, para melhor organização, seja interessante mover sua questão para uma pergunta independente.

Espero ter ajudado.

Um abraço!

editar assinalar como ofensivo Excluir Link mais

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2017-05-09 19:54:24 -0500

Lidas: 369 vezes

Última atualização: May 15 '17