Haz tu Pregunta
0

Errores de la resolución de dependencias: Multilib version problems found.

preguntado 2014-09-02 15:46:37 -0500

Imagen Gravatar de javo_o-
Buen día.

Al querer instalar Skype desde el repo russianfedora-nonfree-updates me aparece el siguiente error:

    *Errores de la resolución de dependencias:

    Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

    1. You have an upgrade for libwayland-server which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of libwayland-server of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude libwayland-server.otherarch ... this should give you an error
    message showing the root cause of the problem.

    2. You have multiple architectures of libwayland-server installed, but
    yum can only see an upgrade for one of those architectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

    3. You have duplicate versions of libwayland-server installed already.
    You can use "yum check" to get yum show these errors.

    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).

    Versiónes multilib protegidas: libwayland-server-1.2.0-3.fc20.i686 != libwayland-server-1.5.0-4.el7.nux.x86_64Versiónes multilib protegidas: libwayland-client-1.2.0-3.fc20.i686 != libwayland-client-1.5.0-4.el7.nux.x86_64*

Agradecere su ayuda.

De antemano gracias
edit re-etiquetar marcar como ofensivo cerrar fusionar delete

1 Responder

Ordenar por » viejos nuevas más votado
0

respondido 2014-09-02 21:17:40 -0500

Imagen Gravatar de davidva

el7??? muy raro.. se me hace que tienes habilitado algun repositorio para Red Hat, esto te va a causar serios problemas como el que tienes ahora, a menos que lo deshabilites o elimines... para resolver este problema elimina todo libwayland-server que no sea para fedora y no sea para tu arquitectura, eso lo puedes hacer listando todos los paquetes libwayland-server que tienes instalados.

yum list libwayland-server

Ahora eliminamos paquetes individuales (con esto nos evitaremos serios problemas con eliminar casi medio escritorio y dejar inutilizable Fedora), que no sean fc20 o pertenezcan a la arquitectura, ojo NO borrar el espeficifico para la fedora 20 en 64bits .

rpm -e --nodeps mi_libwayland-server

Otra opcion, intenta instalar skype por esta via: https://github.com/kuboosoft/skype-installer pero no podras hacer absolutamente nada si no desahabilitas ese repositorio de Red Hat...

edit marcar como ofensivo delete enlace mas

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2014-09-02 15:46:37 -0500

Visto: 858 veces

Ultima actualización: Sep 02 '14