Ask Your Question

Jcmaykin's profile - activity

2014-01-04 16:21:18 -0500 received badge  Taxonomist
2013-12-19 18:14:57 -0500 received badge  Famous Question (source)
2013-12-19 18:14:57 -0500 received badge  Notable Question (source)
2013-10-31 09:32:05 -0500 received badge  Popular Question (source)
2013-10-27 08:56:33 -0500 asked a question Fedora 20 - Gimp constantly shuts down

So I'm not sure what's going on here.

While I was on F19, I had quite a few problems with GIMP, specifically with exporting images.

After an upgrade to F20, the issues went away for a little, but have returned, only this time different.

Gimp will constantly close despite what I do, usually it closes after starting (the moment I move my cursor), other times I'll try to save an image only to close (rather than my previous export bug which just froze it).

I have reinstalled plenty of times and I've cleared it's folder in .config.

Here is what happens in the terminal when I open gimp, open an image and choose to export it as png.

jake@hackur ~$ gimp

(gimp:3827): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",

(gimp:3827): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",

(file-png:3954): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",

(file-png:3954): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",
gimp: cairo-scaled-font.c:459: _cairo_scaled_glyph_page_destroy: Assertion `!scaled_font->cache_frozen' failed.
gimp: terminated: Aborted
jake@hackur ~$ 
(file-png:3954): LibGimp-WARNING **: file-png: gimp_flush(): error: Broken pipe

(file-png:3954): LibGimp-WARNING **: file-png: gimp_flush(): error: Broken pipe

(script-fu:3832): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error

I can't reproduce the random closure when opening from the terminal (e.g. closing after moving the cursor).

Could anyone offer some advice please, maybe I'm missing some dependencies?

Upon inspection

It /appears/ reverting to the default Adwaita gtk theme solves the issue, but is this unsolvable when using any other theme? I have a few themes installed, but all reproduce the issue except for default.

I installed gtk2-engines which seems to have fixed the gtk-warnings though.

2013-09-22 17:46:51 -0500 received badge  Famous Question (source)
2013-09-18 12:16:57 -0500 answered a question Fedora 19 Dracut "swap does not exist" boot error

No help so resorted to doing a fresh install. Problem sorted.

2013-09-18 04:52:01 -0500 received badge  Notable Question (source)
2013-09-17 10:42:41 -0500 received badge  Popular Question (source)
2013-09-17 07:47:35 -0500 commented answer Fedora 19 Dracut "swap does not exist" boot error

So from using the recovery tool on the Fedora 18 disc to allow me to access shell, I did

"chroot /mnt/sysimage" (to run as root) "dracut --regenerate-all --force"

Which resulted in:

"W: Turning off host-only mode: '/run' is not mounted!" "W: Turning off host-only mode: udev database not found!"

Booting back into fedora the error dracut gave me this time only contained one warning: 'Warning /dev/fedora_op/swap does not exist'

The mapper one seems to have disappeared.

2013-09-17 03:21:24 -0500 received badge  Famous Question (source)
2013-09-17 03:21:24 -0500 received badge  Notable Question (source)
2013-09-17 03:21:24 -0500 received badge  Popular Question (source)
2013-09-17 03:20:54 -0500 received badge  Notable Question (source)
2013-09-17 03:20:54 -0500 received badge  Popular Question (source)
2013-09-17 03:06:52 -0500 asked a question Fedora 19 Dracut "swap does not exist" boot error

After trying to remove an old fedora partition I had to remove a swap as I ended up with two, however to remove the old swap I ran swapoff -a which turned all swaps off. I then removed the partition and rebooted.

Upon reboot I was greeted by dracut failing to boot and entering emergency shell, giving me the following error:

Warning /dev/fedora_op/swap does not exist
Warning /dev/mapper/fedora_op/swap does not exist

"Fedora_op" was the old fedora installation, which my current seemed to be using it's swap file since that was created first.

Can I fix this error with a few commands? I'm not in the know.

I also have access to a fedora 18 cd which I have just used to recover the grub menu after installing windows, so I can use the rescue option there to enter the shell too.

2013-07-13 00:46:40 -0500 received badge  Student (source)
2013-07-12 14:38:02 -0500 received badge  Editor (source)
2013-07-12 13:00:38 -0500 asked a question F19 Application Menu bugged?

Hi there, after updating from F18 to F19 my activities/application menu appears to be bugged in a way that not only doesn't look right, some of it's functions have disappeared. In the image here: i.imgur/CNeIuqR.jpg The menu has my old Fedora 18 Desktop Wallpaper in it's background (however my Desktop does not have my old wallpaper, it defaulted to this grey colour as seen here i.imgur/gdi2W8F.png) This was an issue with Gnome-Tweak-Tool's "Have file manager handle desktop" which removed my desktop wallpaper. The other issue still stands. And I am missing the buttons for the new "Frequent" and "All" tabs so at the moment all I can see are my frequent applications and I've had to add an extension (the extra menus in my title bar) to view my other applications for now. Is there a way to fix this? Is this a known bug? Any help would be really appreciated, thank you... (the image links just need a .com, you do not need to view them, though).

So after realising it was just my shell theme, I am sorry for any wasted time. I do not know how to close a question, apparently I do not have enough Karma.

2013-06-04 12:27:58 -0500 received badge  Scholar (source)
2013-06-04 12:25:55 -0500 commented answer F18 No login screen

Hi there, thank you for taking the time to assist me!

I realise after reviewing the content it was outdated, and I regret downloading and using them. However, I sorted the problem out the hard way and reinstalled over an old partition, recovered my files and installed again.

Quite upset all my settings have disappeared, but I guess it's part of exploration.

Sorry I left this up, I completely forgot since it took a while to reinstall.

Again, thank you for the detailed response and if things should go wrong again, I may be able to use what you've provided!

2013-06-03 05:04:16 -0500 commented question F18 No login screen

Hi! The scripts I installed were http://gnome-look.org/content/show.php/Ultimate+Edition+Nautilus+Scripts+Pack?content=104451 and I ran "MakeGDM" and "MakeUsplash" not knowing what they were.

Whether these have done something, I don't know... about this grub boot command line, do you have instructions to achieve that? I'm very new to using linux/grub.

2013-06-03 04:30:29 -0500 asked a question F18 No login screen

Hello, after booting my fedora 18 it loads up until the splash screen (the blue wallpaper before the login area appears).

That's it, it just sits at the splash screen with my cursor available.

I can access TTY (and login as root), but I am new to linux and have no idea what I'm doing. Is there a way to figure out what is wrong, or is there a quick-fix?

I have no idea what the problem is, it was working correctly the other night, however I installed some nautilus scripts and ran one or two i was unsure about to see what they were, and one did something with grub (i think).