Ask Your Question

baitillus's profile - activity

2016-10-12 07:31:43 -0500 received badge  Famous Question (source)
2016-09-06 16:32:00 -0500 received badge  Notable Question (source)
2016-09-06 16:32:00 -0500 received badge  Popular Question (source)
2016-08-20 22:00:23 -0500 received badge  Editor (source)
2016-08-20 18:29:02 -0500 answered a question Browsing and dnf issues in f24, f25 and f26 in Ecuador. Is it about Mirrors, ipv6?

My brother has ubuntu installed on a computer much more powerfull than mine and firefox goes lightning fast on my humble satellite s50-b with fedora 24 compared with he's asus beast. Ubuntu has better driver support though :/

2016-08-20 14:48:05 -0500 asked a question amd graphics drivers Fedora 24

I don't know where to turn. After a reinstall of F24WS I'm unable to control the screen brightness and the screen itself is not properly recognized by the OS (is always shown as unknown display). This not used to happen, before F24 used to work pretty much out of the box. After much reading I can just assume that the problem lies in the graphics cards (On board and AMD) drivers and the kernel not being able to properly communicate with the hardware.

After basically one night troubleshooting the issue nothing, and I mean nothing, seems to work. The catalyst drivers provided for previous versions (namely 22 and 23) don't work any more due to the xorg version (in order to use them I need to downgrade the xorg version to one previous to 11, which I did but was still unable to install them) and AMD now only gives support to some versions of RHEL. Even the generic Linux drivers provided by them do not work.

Can anyone help or point to some directions? I just don't know what more to do. The machine in question is my workhorse, a toshiba satellite s50-B-14d.

Thank you in advance.

ps: I needed to do a fresh install due to the fact that without any tinkering or notice my touchpad right button didn't work properly! It was always having the behaviour expected from the left button.

--Follow up:

My laptop graphics chip is the amd R7 270 and yet this:

[baitillus@satellite ~]$ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

still unable to find anything (I found a lot about nvidia drivers installations and compatibility nothing about amd).

--follow up

after installing amdgpu: lspci -k returns:

09:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360]
    Subsystem: Toshiba America Info Systems Radeon R7 M260
    Kernel modules: amdgpu

and yet my details tell me that the graphics are controled by Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits).

Could this be the source of the problem?