Ask Your Question

galvao's profile - activity

2018-06-22 00:00:05 -0500 received badge  Notable Question (source)
2017-03-06 16:25:27 -0500 received badge  Famous Question (source)
2017-01-29 09:13:07 -0500 received badge  Notable Question (source)
2017-01-29 09:13:07 -0500 received badge  Popular Question (source)
2017-01-13 03:50:43 -0500 answered a question Is fedora KDE spin using wayland?

Not that I know of. My F25 KDE still uses X. As you can see here, Wayland is only mentioned for Gnome users.

2017-01-13 02:53:23 -0500 commented question Tips on reducing disk I/O?

Thank you for your answer. How can I check if all the RAM is being recognized? As of SSD, sure, I plan to use it, but that's a different subject.

2017-01-12 11:05:15 -0500 asked a question Tips on reducing disk I/O?

My installation of Fedora 25 with KDE is having some unnerving issues with disk I/O. It's constant and for some applications (like Firefox and Lollypop, just to name a couple) it sometimes does a huge disk access.

I've done the "usual":

  1. Disabled baloo;
  2. Edited /etc/fstab and put noatime at both root and home (since access time is not a priority for me);
  3. Disabled every automatic indexing present on System Settings (as far as I can tell)

And yet jdb keeps showing up on iotop in ≃10-15s intervals...

Should I put a high "commit" interval at /etc/fstab as well? I mean, since it's a notebook I don't have issues with power failure...

What else can be done? What am I missing?

TIA,

2017-01-05 09:45:20 -0500 received badge  Popular Question (source)
2017-01-05 09:45:17 -0500 received badge  Popular Question (source)
2017-01-05 09:45:15 -0500 received badge  Famous Question (source)
2017-01-05 09:45:15 -0500 received badge  Notable Question (source)
2017-01-04 05:09:47 -0500 received badge  Autobiographer
2017-01-03 19:43:48 -0500 received badge  Scholar (source)
2017-01-03 12:57:46 -0500 answered a question MySQL workbench doesn't work on Fedora 25

OK, nevermind, solved it:

  1. You need to follow their instructions to enable extra MySQL Community repos;
  2. Then install mysql-workbench-community-6.3.8-1.fc24.x86_64.rpm;
  3. It's python2-paramiko (which installs by default as a requirement).
2017-01-03 12:51:24 -0500 asked a question MySQL workbench doesn't work on Fedora 25

So I've downloaded MySQL Workbench's rpm from their site, which specifies it's a F24 release. When I try to install it I get the following errors:

sudo rpm -ivh mysql-workbench-community-6.3.8-1.fc24.x86_64.rpm  
warning: mysql-workbench-community-6.3.8-1.fc24.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
error: Failed dependencies:
        python-paramiko >= 1.15.1 is needed by mysql-workbench-community-6.3.8-1.fc24.x86_64

I have python3-paramiko (from the official Fedora repo, which is version 2.1.1) installed, and yet their package still complains about it.

One thing I've tried was downloading and installing MySQL's official F25 repo, but now it tries to override my current MariaDB installation, which is undesirable (and yes, Workbench works with MariaDB, so no problem there).

Can anyone help?

2016-09-14 13:42:33 -0500 commented answer Any down sides to using an encrypted fs?

Thank you so much. These were the answers I was looking for.

2016-09-14 11:57:22 -0500 asked a question Any down sides to using an encrypted fs?

I'm about to migrate from F23 to F24 and I'm thinking about finally using an encrypted filesystem. Problem is tons of questions come to mind, like:

  1. Are there any (noticeable) performance issues? I notice my day to day routine "causes" a lot of disk I/O, so...
  2. Are there any applications that are "incompatible" with an encrypted filesystem? How about backup apps (e.g. Back In Time)?
  3. How about copying from encrypted to unencrypted? Can I just cp something to a pendrive as usual, for an example?

Sorry that I'm putting more than one question in the same post, but I'm just unsure. Can anyone provide some good reading or some straight answers?

TIA,

2016-05-23 10:21:30 -0500 received badge  Teacher (source)
2016-05-23 10:21:30 -0500 received badge  Self-Learner (source)
2016-05-23 08:32:32 -0500 answered a question Some MP3 players are failing

Alright, so I went crazy and did a sudo dnf install gstreamer* All working now.

2016-05-23 08:11:45 -0500 asked a question Some MP3 players are failing

Been using Clementine for quite a while now and everything always ran smoothly. All of the sudden Clementine started complaining about missing plugins. Tried Yarock, which also fails to play. VLC and XMMS are working good.

Was Gstreamer broken in the recent updates? How can I fix this?

Here's Clementine output:

10:07:45.598 WARN  unknown                          libpng warning: iCCP: known incorrect sRGB profile 
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Next"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Play"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Previous"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Stop"  
10:07:45.780 WARN  unknown                          QPainter::begin: Paint device returned engine == 0, type: 2 
10:07:45.917 WARN  unknown                          Object::connect: No such signal QtSingleApplication::messageReceived(QByteArray) 
10:07:45.917 WARN  unknown                          Object::connect:  (sender name:   'clementine') 
10:07:45.917 WARN  unknown                          Object::connect:  (receiver name: 'MainWindow') 
10:07:57.348 WARN  unknown                          QPainter::begin: Paint device returned engine == 0, type: 2 
10:07:57.348 WARN  unknown                          QPainter::translate: Painter not active 
10:07:57.348 WARN  unknown                          QPainter::save: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::restore: Unbalanced save/restore 
10:07:57.448 WARN  unknown                          QPainter::translate: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::end: Painter not active, aborted 
10:07:57.579 WARN  unknown                          QTimeLine::start: already running 
10:07:57.596 WARN  unknown                          QTimeLine::start: already running

And here is Yarock output:

** Message: PackageKit: xid = 20971524
** Message: PackageKit: desktop_id = (null)
** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: ignoring field named parsed
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=1)(layer=3)()(64bit)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.UnknownInterface: No such interface 'org.freedesktop.PackageKit.Modify2' at object path '/org/freedesktop/PackageKit'
2016-03-13 09:49:27 -0500 answered a question 'which' and JRE problems

So, the whole problem (everything) was related to the fact that which was missing. So after a dnf reinstall which the problem was solved. A piece of advice: I've just remembered that I had a failed installation of Netbeans prior to this happening so, this MIGHT have been the cause of the whole thing.

2016-03-13 06:37:25 -0500 commented question 'which' and JRE problems

That's not the case:

[zaphod@magrathea UrbanTerror42]$ diff /etc/skel/.bashrc ~/.bashrc

11a12,18

if [ -f which powerline-daemon ]; then powerline-daemon -q POWERLINE_BASH_CONTINUATION=1 POWERLINE_BASH_SELECT=1 . /usr/share/powerline/bash/powerline.sh fi Only difference is the powrline block, which always worked perfectly. It still doesn't explain which or jre.

2016-03-13 03:36:49 -0500 asked a question 'which' and JRE problems

I've recently (< than a week) started finding a few problems in my Fedora23:

  1. The 'which' command is gone;
  2. Smartgit (a graphical git client) can't detect my JRE anymore;
  3. I've used to have powerline working on my Konsole and now it's gone all the sudden

I wonder if a recently update broke all of these together or if some other user screwed something in here. Any other people experiencing this kind of thing?

BTW I've ran sudo alternatives to see about my JRE and it's set correctly at /usr/java/jre1.8.0_66/bin/java

TIA,

2016-02-21 03:40:16 -0500 received badge  Popular Question (source)
2016-02-03 18:59:52 -0500 answered a question "Ignoring BGRT" - What is it and should I be worried?

I've been getting it for a long time (but I believe it started displaying when I've switched to Fedora23). It shows after GRUB, right before the boot switches to the graphical interface (KDE). I guess it's nothing to worry then, but the fact it comes in bright yellow suggests otherwise and is a bit concerning.

Thank you all for your answers/comments!

2016-02-02 05:23:37 -0500 received badge  Editor (source)
2016-02-02 00:18:48 -0500 asked a question "Ignoring BGRT" - What is it and should I be worried?

While booting my notebook, Fedora23 displays this message in bright yellow: "Ignoring BGRT: Invalid status 0 (expected 1)".

I'd like to know what this is and if I should be worried about it. Thanks,

2015-12-13 04:30:40 -0500 answered a question error while loading shared libraries: libzip.so.2 mysql-workbench fc23

Having the same issues here. I've received the word from the MySQL Workbench team (via twitter: @MySQLWorkbench) that a version for Fedora 23 is coming soon.

2015-12-09 02:48:11 -0500 commented answer error while loading shared libraries: libzip.so.2 mysql-workbench fc23

I've tried creating a symlink named as libzip.so.2 pointing to libzip.so.4 (both in /usr/lib64) but the error remains the same. Should I do anything else after creating the symlink? What am I missing?

2015-12-06 20:35:36 -0500 received badge  Supporter (source)
2015-12-02 20:37:43 -0500 commented question Alternative tutorials for using fedy

Thanks, @Florian and @randomuser. Should be hitting those links hard in 5-6 days

2015-12-01 06:45:40 -0500 commented question Alternative tutorials for using fedy

Found most of them, but the one I predict I'll have most problems with - since it has few questions and most of them address Gnome installations (mine will be KDE) - is the font rendering.

2015-11-30 10:38:25 -0500 received badge  Student (source)
2015-11-30 09:18:43 -0500 asked a question Alternative tutorials for using fedy

I've recently saw the "Never use Fedy" message on #fedora (Freenode) and since I plan to do a fresh install (Fedora 23) in a couple of weeks I was wondering: Where can I find easy and clear tutorials that teach the things Fedy facilitate?

These are the items in Fedy I'm particularly interested in (I assume some of those are easy as pie, but just to make sure):

  • Installing Chrome
  • Installing the Flash player
  • Installing Atom
  • Microsoft TrueType core fonts
  • Multimedia codecs
  • Skype
  • The "better font rendering" tweak

Thanks in advance,