Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No external monitor detected on optimus enabled nvidia gtx 1060 laptop running fedora 25

Hello,

I am unable to get external display connected through hdmi detected on my new laptop with fedora 25. The system settings "Display" shows only the builtin screen. So does xrandr, both when runnin Wayland and Xorg. This is an optimus enabled Japanese laptop (GALLERIA QSF1060HE), with Intel HD 530 (Skylake GT2) and Nvidia 1060.

I am not sure, but I have a suspicion that the HDMI port may be connected to nvidia (not sure how to check it), so I need to get the nvidia running.

1) When I tried bumblebee, the boot hangs just after displaying the fedora logo. I can only power off the computer. 2) I tried to install nvidia drivers from the nvidia webpage, but then: a) when using Xorg, it blinks the screen a lot while still in the text boot phase, and displays "starting session ... 1" up to 74. Then stops, no GUI is displayed. I can switch to other console though. b) With Wayland it doesn't display so many "starting session", but also does not display GUI

So, to summarise: most important for me is to get the external display running. Any help apprieciated. I can attach the logs that you think may be helpful