Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 25 thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2  
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and set to on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Fedora 25 thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25.25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2  
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and set to on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2  
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64  
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and set to shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2  
vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64  
vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64  
vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Update:

I noticed that airplane mode is off for a few seconds after login (though it might be only the first time after booting—I'll confirm). It is long enough to select a wi-fi network and start typing a password. Perhaps a login setting is forcing airplane mode on?

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Update:

I noticed that airplane mode is off for a few seconds after login (though it might be is only the first time after booting—I'll confirm). booting and if the airplane mode switch is off). It is long enough to select a wi-fi network and start typing a password. Perhaps a login setting is forcing airplane mode on?on? I tried this also with a newly created user and it behaves the same way as my usual login.

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Update:Update 1:

I noticed that airplane mode is off for a few seconds after login (though it is only the first time after booting and if the airplane mode switch is off). It is long enough to select a wi-fi network and start typing a password. Perhaps a login setting is forcing airplane mode on? I tried this also with a newly created user and it behaves the same way as my usual login.

Update 2:

Since the upgrade was done through the dnf system-upgrade, I didn't see an explicit check of the file checksum, so it has lingered in the back of my mind that maybe a system file is corrupted. To address this concern, I downloaded the workstation live .iso image and booted that. No configuration necessary: the live image always things airplane mode is on.

Fedora 25 always thinks airplane mode is enabled

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Update 1:

I noticed that airplane mode is off for a few seconds after login (though it is only the first time after booting and if the airplane mode switch is off). It is long enough to select a wi-fi network and start typing a password. Perhaps a login setting is forcing airplane mode on? I tried this also with a newly created user and it behaves the same way as my usual login.

Update 2:

Since the upgrade was done through the dnf system-upgrade, I didn't see an explicit check of the file checksum, so it has lingered in the back of my mind that maybe a system file is corrupted. To address this concern, I downloaded the workstation live .iso image and booted that. No configuration necessary: the live image always things thinks airplane mode is on.