Ask Your Question

Revision history [back]

Microsoft Wireless Sculpt Keyboard

Hello,

I recently bought a Microsoft Sculpt Ergonomic Keyboard. After plugging it into my desktop, running Fedora 24, I found that certain keys are not working properly. These are the media hotkeys (play/pause, mute, volume up, volume down, calculator) under the function keys F9-F12.

I first thought the keyboard was defective but as I tried it in my laptop also running Fedora 24 they all work properly.

My first thought was that I needed to update the system on my desktop. This did not have any effect on the keyboard.

My second thought was the graphics card. This proved semi-fruitful as I removed my NVIDIA drivers from the desktop and voila the keys worked. In my stupidity I tried to reinstall the nvidia drivers from RPMFusion (I tried unitedrpms previously) they stopped to work. I removed the nvidia drivers a second time and the buttons continued to not work.

Now in my confusion I feel I have created some kind of franken system of graphics card packages and nothing seems to work overly well anymore. I now experience random freezing and other issues. My system does not seem to have nvidia installed anymore but the graphics now seem unstable.

Sorry for the rambling message, it has been a long day caused by a stupid keyboard. Has anyone experienced this before or does anyone know of a way to trouble shoot the media keys?

I am debating a fresh install of F24 but I would prefer that be a last resort.