Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 24 - install Kazam - Error: nothing provides python(abi) = 3.4 needed by kazam

I'm trying to install Kazam (screen recorder) in Fedora 24. In Fedora 23, That's work without any problem, but in 24, when I'm type sudo dnf install kazam-1.4.5-3.1.noarch.rpm (after I installed a couple of python packages which was required by Kazam) it's print this

[noam@localhost-localdomain 1]$ 
[noam@localhost-localdomain 1]$ sudo dnf install kazam-1.4.5-3.1.noarch.rpm
Last metadata expiration check: 0:17:28 ago on Thu Jul 21 13:40:17 2016.
Error: nothing provides python(abi) = 3.4 needed by kazam-1.4.5-3.1.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)
[noam@localhost-localdomain 1]$

(and --allowerasing do nothing) So I searched on google, and found this commands

[noam@localhost-localdomain 1]$ 
[noam@localhost-localdomain 1]$ rpm -q --provides python | grep -Fw 'python(abi)'
python(abi) = 2.7
python(abi) = 2.7
[noam@localhost-localdomain 1]$

So I guess I need to update the python abi (which I'm not really sure what is it) / installer a newer python abi - if this is the case - how can I do that? How can I update the python abi / install a newer version?

p.s - There is any other good screen recorder software? (I don't like gtk-recordmydesktop, because it have very minimal options, and it always record from mic and show the cursor - there is no many options in this software..)

Thanks, Noam