Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Cannot boot rescue initramfs

When I boot the Fedora 23 rescue initramfs, my encryption passphrase is always wrong. When I boot a normal initramfs it works.

Maybe unrelated but suspect: for every character of my passphrase that I type, a new "Enter passphrase" line appears.

I already tried rebuilding the rescue image, using this command, but I had no luck:

dracut --no-hostonly -a rescue --force /boot/initramfs-0-rescue-c4add09518e74f8da79473474fc30542.img 4.2.8-300.fc23.x86_64

I'm using the german keyboard layout but all characters of my passphrase have the same position on the english layout so I think it's not a keyboard layout problem.

Here is an photo: https://gist.github.com/fnkr/12df359b88272db4a3af

Cannot boot open luks container with rescue initramfs

When I boot the Fedora 23 rescue initramfs, my encryption passphrase is always wrong. When I boot a normal initramfs it works.

Maybe unrelated but suspect: for every character of my passphrase that I type, a new "Enter passphrase" line appears.

I already tried rebuilding the rescue image, using this command, but I had no luck:

dracut --no-hostonly -a rescue --force /boot/initramfs-0-rescue-c4add09518e74f8da79473474fc30542.img 4.2.8-300.fc23.x86_64

I'm using the german keyboard layout but all characters of my passphrase have the same position on the english layout so I think it's not a keyboard layout problem.

Here is an photo: https://gist.github.com/fnkr/12df359b88272db4a3af

Cannot open luks container with rescue initramfs

When I boot the Fedora 23 rescue initramfs, my encryption passphrase is always wrong. When I boot a normal initramfs it works.

Maybe unrelated but suspect: for every character of my passphrase that I type, a new "Enter passphrase" line appears.

I already tried rebuilding the rescue image, using this command, but I had no luck:

dracut --no-hostonly -a rescue --force /boot/initramfs-0-rescue-c4add09518e74f8da79473474fc30542.img 4.2.8-300.fc23.x86_64

I'm using the german keyboard layout but all characters of my passphrase have the same position on the english layout so I think it's not a keyboard layout problem.

Here is an a photo: https://gist.github.com/fnkr/12df359b88272db4a3af

Cannot open luks container with rescue initramfs

When I boot the Fedora 23 rescue initramfs, my encryption passphrase is always wrong. When I boot a normal initramfs it works.

Maybe unrelated but suspect: for every character of my passphrase that I type, a new "Enter passphrase" line appears.

I already tried rebuilding the rescue image, using this command, but I had no luck:

dracut --no-hostonly -a rescue --force /boot/initramfs-0-rescue-c4add09518e74f8da79473474fc30542.img 4.2.8-300.fc23.x86_64

I'm using the german keyboard layout but all characters of my passphrase have the same position on the english layout so I think it's not a keyboard layout problem.

Here is a photo: https://gist.github.com/fnkr/12df359b88272db4a3af

Cannot open luks container with rescue initramfs

When I boot the Fedora 23 rescue initramfs, my encryption passphrase is always wrong. When I boot a normal initramfs it works.

Maybe unrelated but suspect: for every character of my passphrase that I type, a new "Enter passphrase" line appears.

I already tried rebuilding the rescue image, using this command, but I had no luck:

dracut --no-hostonly -a rescue --force /boot/initramfs-0-rescue-c4add09518e74f8da79473474fc30542.img 4.2.8-300.fc23.x86_64

I'm using the german keyboard layout but all characters of my passphrase have the same position on the english layout so I think it's not a keyboard layout problem.