Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 23 won't boot with nvidia-only setup on lenovo T420

I have the Lenovo T420 laptop which has optimus. However I would like to throw optimus away and use the discrete graphics only. So I went to BIOS and set it up so that only the discrete card is used. However, in this setting, Fedora won't boot at all - afer selecting the grub item, all monitors (i tried these configurations: laptop only, laptop + VGA connected monitor, laptop + DP connected monitor, laptop + VGA + DB connected monitors), including the built-in laptop display, go black and the CPU fan starts to spin very rapidly . From this state I can't do anything except manually turning the computer off. I also tried to install nvidia drivers according to this guide but the result is identical - blank screen(s) and CPU fan running at the top speed.

When I use the optimus or integrated-only setting in BIOS then fedora boots ok.

Could anyone give me a hint at what might be wrong?