Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

'nvidia-xconfig' breaks X.

  • Fedora 17
  • Lenovo Z580
  • Kernel 3.5.4-1 or 3.5.3-1

I recently updated the kernel and since then my nvidia chip and Bumblebee do not run.

I followed this guide again to reinstall Bumblebee.

However, optirun gives

[ERROR] The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

When I go to the NVIDIA X Server Settings I get

You do not appear to be using NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

However, upon doing that, the system hangs at [OK] started device manager and using startx gives

ERROR: could not insert 'nvidia':No such file or directory

Fatal server error: no screens found

Xorg.0.log states:

(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver   
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages.  
(II) UnloadModule:    "nvidia"     
(II) Unloading nvidia     
(EE) Failed to load module "nvidia" (module-specific error, 0)  
(EE) No drivers available.

messages reads:

bumblebeed[2511]: [ERROR] Module 'nvidia' is not found.

Only upon deleting xorg.conf do I get the GUI login again but no 3D programs run complaining about missing GLX.

Thanks.

'nvidia-xconfig' breaks X.

  • Fedora 17
  • Lenovo Z580
  • Kernel 3.5.4-1 or 3.5.3-1

I recently updated the kernel and since then my nvidia chip and Bumblebee do not run.

I followed this guide again to reinstall Bumblebee.

However, optirun gives

[ERROR] The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

When I go to the NVIDIA X Server Settings I get

You do not appear to be using NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

However, upon doing that, the system hangs at [OK] started device managerStarted display manager. and using startx gives

ERROR: could not insert 'nvidia':No such file or directory

Fatal server error: no screens found

Xorg.0.log states:

(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver   
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages.  
(II) UnloadModule:    "nvidia"     
(II) Unloading nvidia     
(EE) Failed to load module "nvidia" (module-specific error, 0)  
(EE) No drivers available.

messages reads:

bumblebeed[2511]: [ERROR] Module 'nvidia' is not found.

Only upon deleting xorg.conf do I get the GUI login again but no 3D programs run complaining about missing GLX.

Thanks.

[SOLVED] 'nvidia-xconfig' breaks X.

  • Fedora 17
  • Lenovo Z580
  • Kernel 3.5.4-1 or 3.5.3-1

I recently updated the kernel and since then my nvidia chip and Bumblebee do not run.

I followed this guide again to reinstall Bumblebee.

However, optirun gives

[ERROR] The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

When I go to the NVIDIA X Server Settings I get

You do not appear to be using NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

However, upon doing that, the system hangs at [OK] Started display manager. and using startx gives

ERROR: could not insert 'nvidia':No such file or directory

Fatal server error: no screens found

Xorg.0.log states:

(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver   
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages.  
(II) UnloadModule:    "nvidia"     
(II) Unloading nvidia     
(EE) Failed to load module "nvidia" (module-specific error, 0)  
(EE) No drivers available.

messages reads:

bumblebeed[2511]: [ERROR] Module 'nvidia' is not found.

Only upon deleting xorg.conf do I get the GUI login again but no 3D programs run complaining about missing GLX.

Thanks.

click to hide/show revision 4
no need to say "solved", since this is a qa site and not a traditional forum. just mark an answer accepted (even your own)

[SOLVED] 'nvidia-xconfig' breaks X.

  • Fedora 17
  • Lenovo Z580
  • Kernel 3.5.4-1 or 3.5.3-1

I recently updated the kernel and since then my nvidia chip and Bumblebee do not run.

I followed this guide again to reinstall Bumblebee.

However, optirun gives

[ERROR] The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

When I go to the NVIDIA X Server Settings I get

You do not appear to be using NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

However, upon doing that, the system hangs at [OK] Started display manager. and using startx gives

ERROR: could not insert 'nvidia':No such file or directory

Fatal server error: no screens found

Xorg.0.log states:

(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver   
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages.  
(II) UnloadModule:    "nvidia"     
(II) Unloading nvidia     
(EE) Failed to load module "nvidia" (module-specific error, 0)  
(EE) No drivers available.

messages reads:

bumblebeed[2511]: [ERROR] Module 'nvidia' is not found.

Only upon deleting xorg.conf do I get the GUI login again but no 3D programs run complaining about missing GLX.

Thanks.