Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

can't mount usb drive

Lately, I'm having problem mounting my USB drive. Upon connecting the USB drive, this shows up in /var/log/messages:

Apr 11 11:53:25 fong-home kernel: [34720.510179] usb 1-2.2: new high-speed USB device number 7 using ehci_hcd Apr 11 11:53:25 fong-home kernel: [34720.596050] usb 1-2.2: New USB device found, idVendor=13fd, idProduct=1840 Apr 11 11:53:25 fong-home kernel: [34720.596056] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3 Apr 11 11:53:25 fong-home kernel: [34720.596059] usb 1-2.2: Product: External
Apr 11 11:53:25 fong-home kernel: [34720.596062] usb 1-2.2: Manufacturer: Generic Apr 11 11:53:25 fong-home kernel: [34720.596065] usb 1-2.2: SerialNumber: 35514A304142464420202020 Apr 11 11:53:25 fong-home kernel: [34720.596494] scsi13 : usb-storage 1-2.2:1.0 Apr 11 11:53:25 fong-home mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.2" Apr 11 11:53:25 fong-home mtp-probe: bus: 1, device: 7 was not an MTP device Apr 11 11:53:26 fong-home kernel: [34721.596729] scsi 13:0:0:0: Direct-Access Generic External 1.08 PQ: 0 ANSI: 4 Apr 11 11:53:26 fong-home kernel: [34721.597879] sd 13:0:0:0: Attached scsi generic sg4 type 0 Apr 11 11:53:26 fong-home kernel: [34721.598459] sd 13:0:0:0: [sdd] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB) Apr 11 11:53:26 fong-home kernel: [34721.599084] sd 13:0:0:0: [sdd] Write Protect is off Apr 11 11:53:26 fong-home kernel: [34721.599710] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.599714] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.601581] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.601585] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.631999] sdd: sdd1 Apr 11 11:53:26 fong-home kernel: [34721.634206] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.634211] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.634215] sd 13:0:0:0: [sdd] Attached SCSI disk Apr 11 11:53:26 fong-home multipathd: sdd: add path (uevent) Apr 11 11:53:26 fong-home multipathd: failed to find rport_id for target13:0:0 Apr 11 11:53:26 fong-home multipathd: 1Generic_External: load table [0 1953525168 multipath 0 0 1 1 round-robin 0 1 1 8:48 1000] Apr 11 11:53:26 fong-home multipathd: 1Generic_External: event checker started Apr 11 11:53:26 fong-home multipathd: sdd path added to devmap 1Generic_External

The partition device node doesn't get created:

[root@fong-home sbin]# ls /dev/sdd* /dev/sdd

But the partition is there:

[root@fong-home sbin]# fdisk -l /dev/sdd

Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes 255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x097aef9d

Device Boot Start End Blocks Id System /dev/sdd1 63 1953520064 976760001 83 Linux

partprobe creates sdd1:

[root@fong-home sbin]# partprobe /dev/sdd [root@fong-home sbin]# ls -l /dev/sdd* brw-rw---- 1 root disk 8, 48 Apr 11 11:55 /dev/sdd brw-rw---- 1 root disk 8, 49 Apr 11 11:55 /dev/sdd1

Can't mount it though -- keeps saying it's mounted but it's not:

[root@fong-home sbin]# mount /dev/sdd1 /a mount: /dev/sdd1 already mounted or /a busy [root@fong-home sbin]# df -h Filesystem Size Used Avail Use% Mounted on rootfs 50G 18G 31G 37% / devtmpfs 3.9G 4.0K 3.9G 1% /dev tmpfs 3.9G 408K 3.9G 1% /dev/shm /dev/mapper/vg_fonghome-lv_root 50G 18G 31G 37% / tmpfs 3.9G 49M 3.9G 2% /run tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup tmpfs 3.9G 0 3.9G 0% /media /dev/md127 1.9T 599G 1.2T 34% /data2 /dev/sda2 497M 94M 378M 20% /boot /dev/mapper/vg_fonghome-lv_home 405G 14G 372G 4% /home

I'm running kernel 3.2.7-1.fc16.x86_64 on FC16. The system is update to date, but I cannot run a newer kernel after 3.2.7 (I have another thread on this) otherwise I loose access to my Linux software RAID (mounted above in /data2).

What is going on there? I'm contemplating moving off of FC to Ubuntu where I was on before.

Thanks in advance for any help.

can't mount usb drive

Lately, I'm having problem mounting my USB drive. Upon connecting the USB drive, this shows up in /var/log/messages:

Apr 11 11:53:25 fong-home kernel: [34720.510179] usb 1-2.2: new high-speed USB device number 7 using ehci_hcd
Apr 11 11:53:25 fong-home kernel: [34720.596050] usb 1-2.2: New USB device found, idVendor=13fd, idProduct=1840
Apr 11 11:53:25 fong-home kernel: [34720.596056] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 11 11:53:25 fong-home kernel: [34720.596059] usb 1-2.2: Product: External 
Apr 11 11:53:25 fong-home kernel: [34720.596062] usb 1-2.2: Manufacturer: Generic Apr 11 11:53:25 fong-home kernel: [34720.596065] usb 1-2.2: SerialNumber: 35514A304142464420202020 Apr 11 11:53:25 fong-home kernel: [34720.596494] scsi13 : usb-storage 1-2.2:1.0 Apr 11 11:53:25 fong-home mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.2" Apr 11 11:53:25 fong-home mtp-probe: bus: 1, device: 7 was not an MTP device Apr 11 11:53:26 fong-home kernel: [34721.596729] scsi 13:0:0:0: Direct-Access Generic External 1.08 PQ: 0 ANSI: 4 Apr 11 11:53:26 fong-home kernel: [34721.597879] sd 13:0:0:0: Attached scsi generic sg4 type 0 Apr 11 11:53:26 fong-home kernel: [34721.598459] sd 13:0:0:0: [sdd] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB) Apr 11 11:53:26 fong-home kernel: [34721.599084] sd 13:0:0:0: [sdd] Write Protect is off Apr 11 11:53:26 fong-home kernel: [34721.599710] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.599714] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.601581] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.601585] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.631999] sdd: sdd1 Apr 11 11:53:26 fong-home kernel: [34721.634206] sd 13:0:0:0: [sdd] No Caching mode page present Apr 11 11:53:26 fong-home kernel: [34721.634211] sd 13:0:0:0: [sdd] Assuming drive cache: write through Apr 11 11:53:26 fong-home kernel: [34721.634215] sd 13:0:0:0: [sdd] Attached SCSI disk Apr 11 11:53:26 fong-home multipathd: sdd: add path (uevent) Apr 11 11:53:26 fong-home multipathd: failed to find rport_id for target13:0:0 Apr 11 11:53:26 fong-home multipathd: 1Generic_External: load table [0 1953525168 multipath 0 0 1 1 round-robin 0 1 1 8:48 1000] Apr 11 11:53:26 fong-home multipathd: 1Generic_External: event checker started Apr 11 11:53:26 fong-home multipathd: sdd path added to devmap 1Generic_External

1Generic_External

The partition device node doesn't get created:

[root@fong-home sbin]# ls /dev/sdd*
/dev/sdd

/dev/sdd

But the partition is there:

[root@fong-home sbin]# fdisk -l /dev/sdd

/dev/sdd Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes 255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x097aef9d

0x097aef9d Device Boot Start End Blocks Id System /dev/sdd1 63 1953520064 976760001 83 Linux

Linux

partprobe creates sdd1:

[root@fong-home sbin]# partprobe /dev/sdd
[root@fong-home sbin]# ls -l /dev/sdd*
brw-rw---- 1 root disk 8, 48 Apr 11 11:55 /dev/sdd
brw-rw---- 1 root disk 8, 49 Apr 11 11:55 /dev/sdd1

/dev/sdd1

Can't mount it though -- keeps saying it's mounted but it's not:

[root@fong-home sbin]# mount /dev/sdd1 /a
mount: /dev/sdd1 already mounted or /a busy
[root@fong-home sbin]# df -h
Filesystem                       Size  Used Avail Use% Mounted on
rootfs                            50G   18G   31G  37% /
devtmpfs                         3.9G  4.0K  3.9G   1% /dev
tmpfs                            3.9G  408K  3.9G   1% /dev/shm
/dev/mapper/vg_fonghome-lv_root   50G   18G   31G  37% /
tmpfs                            3.9G   49M  3.9G   2% /run
tmpfs                            3.9G     0  3.9G   0% /sys/fs/cgroup
tmpfs                            3.9G     0  3.9G   0% /media
/dev/md127                       1.9T  599G  1.2T  34% /data2
/dev/sda2                        497M   94M  378M  20% /boot
/dev/mapper/vg_fonghome-lv_home  405G   14G  372G   4% /home

/home

I'm running kernel 3.2.7-1.fc16.x86_64 on FC16. The system is update to date, but I cannot run a newer kernel after 3.2.7 (I have another thread on this) otherwise I loose access to my Linux software RAID (mounted above in /data2).

What is going on there? I'm contemplating moving off of FC to Ubuntu where I was on before.

Thanks in advance for any help.

can't mount usb drive

Lately, I'm having problem mounting my USB drive. Upon connecting the USB drive, this shows up in /var/log/messages:

Apr 11 11:53:25 fong-home kernel: [34720.510179] usb 1-2.2: new high-speed USB device number 7 using ehci_hcd
Apr 11 11:53:25 fong-home kernel: [34720.596050] usb 1-2.2: New USB device found, idVendor=13fd, idProduct=1840
Apr 11 11:53:25 fong-home kernel: [34720.596056] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 11 11:53:25 fong-home kernel: [34720.596059] usb 1-2.2: Product: External        
Apr 11 11:53:25 fong-home kernel: [34720.596062] usb 1-2.2: Manufacturer: Generic 
Apr 11 11:53:25 fong-home kernel: [34720.596065] usb 1-2.2: SerialNumber: 35514A304142464420202020
Apr 11 11:53:25 fong-home kernel: [34720.596494] scsi13 : usb-storage 1-2.2:1.0
Apr 11 11:53:25 fong-home mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.2"
Apr 11 11:53:25 fong-home mtp-probe: bus: 1, device: 7 was not an MTP device
Apr 11 11:53:26 fong-home kernel: [34721.596729] scsi 13:0:0:0: Direct-Access     Generic  External         1.08 PQ: 0 ANSI: 4
Apr 11 11:53:26 fong-home kernel: [34721.597879] sd 13:0:0:0: Attached scsi generic sg4 type 0
Apr 11 11:53:26 fong-home kernel: [34721.598459] sd 13:0:0:0: [sdd] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
Apr 11 11:53:26 fong-home kernel: [34721.599084] sd 13:0:0:0: [sdd] Write Protect is off
Apr 11 11:53:26 fong-home kernel: [34721.599710] sd 13:0:0:0: [sdd] No Caching mode page present
Apr 11 11:53:26 fong-home kernel: [34721.599714] sd 13:0:0:0: [sdd] Assuming drive cache: write through
Apr 11 11:53:26 fong-home kernel: [34721.601581] sd 13:0:0:0: [sdd] No Caching mode page present
Apr 11 11:53:26 fong-home kernel: [34721.601585] sd 13:0:0:0: [sdd] Assuming drive cache: write through
Apr 11 11:53:26 fong-home kernel: [34721.631999]  sdd: sdd1
Apr 11 11:53:26 fong-home kernel: [34721.634206] sd 13:0:0:0: [sdd] No Caching mode page present
Apr 11 11:53:26 fong-home kernel: [34721.634211] sd 13:0:0:0: [sdd] Assuming drive cache: write through
Apr 11 11:53:26 fong-home kernel: [34721.634215] sd 13:0:0:0: [sdd] Attached SCSI disk
Apr 11 11:53:26 fong-home multipathd: sdd: add path (uevent)
Apr 11 11:53:26 fong-home multipathd: failed to find rport_id for target13:0:0
Apr 11 11:53:26 fong-home multipathd: 1Generic_External: load table [0 1953525168 multipath 0 0 1 1 round-robin 0 1 1 8:48 1000]
Apr 11 11:53:26 fong-home multipathd: 1Generic_External: event checker started
Apr 11 11:53:26 fong-home multipathd: sdd path added to devmap 1Generic_External

The partition device node doesn't get created:

[root@fong-home sbin]# ls /dev/sdd*
/dev/sdd

But the partition is there:

[root@fong-home sbin]# fdisk -l /dev/sdd

Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x097aef9d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1              63  1953520064   976760001   83  Linux

partprobe creates sdd1:

[root@fong-home sbin]# partprobe /dev/sdd
[root@fong-home sbin]# ls -l /dev/sdd*
brw-rw---- 1 root disk 8, 48 Apr 11 11:55 /dev/sdd
brw-rw---- 1 root disk 8, 49 Apr 11 11:55 /dev/sdd1

Can't mount it though -- keeps saying it's mounted but it's not:

[root@fong-home sbin]# mount /dev/sdd1 /a
mount: /dev/sdd1 already mounted or /a busy
[root@fong-home sbin]# df -h
Filesystem                       Size  Used Avail Use% Mounted on
rootfs                            50G   18G   31G  37% /
devtmpfs                         3.9G  4.0K  3.9G   1% /dev
tmpfs                            3.9G  408K  3.9G   1% /dev/shm
/dev/mapper/vg_fonghome-lv_root   50G   18G   31G  37% /
tmpfs                            3.9G   49M  3.9G   2% /run
tmpfs                            3.9G     0  3.9G   0% /sys/fs/cgroup
tmpfs                            3.9G     0  3.9G   0% /media
/dev/md127                       1.9T  599G  1.2T  34% /data2
/dev/sda2                        497M   94M  378M  20% /boot
/dev/mapper/vg_fonghome-lv_home  405G   14G  372G   4% /home

I'm running kernel 3.2.7-1.fc16.x86_64 on FC16. The system is update to date, but I cannot run a newer kernel after 3.2.7 (I have another thread on this) otherwise I loose access to my Linux software RAID (mounted above in /data2).

What is going on there? I'm contemplating moving off of FC to Ubuntu where I was on before.

Thanks in advance for any help.