Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

unable to load midnight commander with glib

I recently tried to load MC (midnight commander) but I received the following errors from ./configure.

sudo ./configure [sudo] password for gb: checking for a BSD-compatible install... /bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking build system type... x86_64-unknown-linux checking host system type... x86_64-unknown-linux checking for style of include used by make... GNU checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking dependency style of gcc... gcc3 checking how to run the C preprocessor... gcc -E checking for egrep... grep -E checking for AIX... no checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking minix/config.h usability... no checking minix/config.h presence... no checking for minix/config.h... no checking for library containing strerror... none required checking for pkg-config... /bin/pkg-config checking for glib-2.0... checking for glib-config... no checking for glib12-config... no checking for glib-config... no checking for GLIB - version >= 1.2.6... no * The glib-config script installed by GLIB could not be found If GLIB was installed in PREFIX, make sure PREFIX/bin is in your path, or set the GLIB_CONFIG environment variable to the * full path to glib-config. configure: error: Test for glib failed. GNU Midnight Commander requires glib 1.2.6 or above.

I checked to see that glib was installed.

[gb@bluuna mc-4.6.1]$ rpm -ql glib /usr/lib64/libglib-1.2.so.0 /usr/lib64/libglib-1.2.so.0.0.10 /usr/lib64/libgmodule-1.2.so.0 /usr/lib64/libgmodule-1.2.so.0.0.10 /usr/lib64/libgthread-1.2.so.0 /usr/lib64/libgthread-1.2.so.0.0.10 /usr/share/doc/glib-1.2.10 /usr/share/doc/glib-1.2.10/AUTHORS /usr/share/doc/glib-1.2.10/COPYING /usr/share/doc/glib-1.2.10/ChangeLog /usr/share/doc/glib-1.2.10/NEWS /usr/share/doc/glib-1.2.10/README

I tried every link I know how do using env and could not get it to work. I am using fedora 17. Thanks for the help.

wsv123456

unable to load midnight commander with glib

I recently tried to load MC (midnight commander) but I received the following errors from ./configure.

sudo ./configure
[sudo] password for gb: 
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux
checking host system type... x86_64-unknown-linux
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for AIX... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking for library containing strerror... none required
checking for pkg-config... /bin/pkg-config
checking for glib-2.0... checking for glib-config... no
checking for glib12-config... no
checking for glib-config... no
checking for GLIB - version >= 1.2.6... no
* *** The glib-config script installed by GLIB could not be found
 *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
 *** your path, or set the GLIB_CONFIG environment variable to the
* *** full path to glib-config.
configure: error: Test for glib failed.
GNU Midnight Commander requires glib 1.2.6 or above.

above.

I checked to see that glib was installed.

[gb@bluuna mc-4.6.1]$ rpm -ql glib
/usr/lib64/libglib-1.2.so.0
/usr/lib64/libglib-1.2.so.0.0.10
/usr/lib64/libgmodule-1.2.so.0
/usr/lib64/libgmodule-1.2.so.0.0.10
/usr/lib64/libgthread-1.2.so.0
/usr/lib64/libgthread-1.2.so.0.0.10
/usr/share/doc/glib-1.2.10
/usr/share/doc/glib-1.2.10/AUTHORS
/usr/share/doc/glib-1.2.10/COPYING
/usr/share/doc/glib-1.2.10/ChangeLog
/usr/share/doc/glib-1.2.10/NEWS
/usr/share/doc/glib-1.2.10/README

/usr/share/doc/glib-1.2.10/README

I tried every link I know how do using env and could not get it to work. I am using fedora 17. Thanks for the help.

wsv123456

unable to load midnight commander with glib

I recently tried to load MC (midnight commander) but I received the following errors from ./configure.

sudo ./configure
[sudo] password for gb: 
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux
checking host system type... x86_64-unknown-linux
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for AIX... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking for library containing strerror... none required
checking for pkg-config... /bin/pkg-config
checking for glib-2.0... checking for glib-config... no
checking for glib12-config... no
checking for glib-config... no
checking for GLIB - version >= 1.2.6... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: Test for glib failed.
GNU Midnight Commander requires glib 1.2.6 or above.

I checked to see that glib was installed.

[gb@bluuna mc-4.6.1]$ rpm -ql glib
/usr/lib64/libglib-1.2.so.0
/usr/lib64/libglib-1.2.so.0.0.10
/usr/lib64/libgmodule-1.2.so.0
/usr/lib64/libgmodule-1.2.so.0.0.10
/usr/lib64/libgthread-1.2.so.0
/usr/lib64/libgthread-1.2.so.0.0.10
/usr/share/doc/glib-1.2.10
/usr/share/doc/glib-1.2.10/AUTHORS
/usr/share/doc/glib-1.2.10/COPYING
/usr/share/doc/glib-1.2.10/ChangeLog
/usr/share/doc/glib-1.2.10/NEWS
/usr/share/doc/glib-1.2.10/README

I tried every link I know how do using env and could not get it to work. I am using fedora 17. Thanks for the help.

wsv123456