Ask Your Question

Revision history [back]

Problem mounting external storage

For some reason whenever I plug in my external ssd (crucial m4 in a sata to usb3 enclosure) the drive does not appear to mount. When I run sudo mount /dev/sdc1 it returns:

Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command.

but it doesn't appear in any of the usual places.

Running sudo fuser -m /dev/sda1 returns the PID corresponding to mount.ntfs-3g

When plugging in the disk, the output of dmesg is:

[ 1517.725319] usb 2-1: new SuperSpeed USB device number 8 using xhci_hcd
[ 1517.737627] usb 2-1: New USB device found, idVendor=13fd, idProduct=3920
[ 1517.737634] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1517.737638] usb 2-1: Product: External
[ 1517.737641] usb 2-1: Manufacturer: Generic 
[ 1517.737643] usb 2-1: SerialNumber: 303030303030303031323038
[ 1517.739041] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 1517.740164] scsi host12: usb-storage 2-1:1.0
[ 1518.744056] scsi 12:0:0:0: Direct-Access     Generic  External         0205 PQ: 0 ANSI: 6
[ 1518.744975] sd 12:0:0:0: Attached scsi generic sg3 type 0
[ 1518.745775] sd 12:0:0:0: [sdc] Spinning up disk...
[ 1521.918192] .ready
[ 1521.918550] sd 12:0:0:0: [sdc] 250069679 512-byte logical blocks: (128 GB/119 GiB)
[ 1521.919101] sd 12:0:0:0: [sdc] Write Protect is off
[ 1521.919107] sd 12:0:0:0: [sdc] Mode Sense: 1f 00 10 08
[ 1521.919701] sd 12:0:0:0: [sdc] Write cache: enabled, read cache: enabled, supports DPO and FUA
[ 1521.924100]  sdc: unknown partition table
[ 1521.925741] sd 12:0:0:0: [sdc] Attached SCSI disk

One unusual thing I've noticed is that when I run gparted, the disk appears to mount flawlessly, and the following 2 lines are added to the output of dmesg:

[ 1794.970285]  sdc: sdc1
[ 1794.973403]  sdc: sdc1

I made sure to format the drive with an msdos partition table and FAT32 filesystem for compatibility, and there is no entry for this disk in /etc/fstab which rules out the 2 sources of similar problems I've found in my research. I'd really appreciate any help on how to get this drive to mount properly without running gparted everytime.