Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

NVIDIA Driver Installation Failure on Fedora 20

I've been following all three of the following guides in order to to install the NVIDIA drivers on Fedora 20:

http://rpmfusion.org/Howto/nVidia http://www.if-not-true-then-false.com/2014/fedora-20-nvidia-guide/ https://ask.fedoraproject.org/en/question/10603/f18-how-to-install-nvidia-drivers/

All three basically say the same thing, and I've previously had success with these guides, but the GNOME display driver fails to start up on my newer machine.

I'm not sure if it makes a difference, but I'm using a Geforce 970 card.

I've been repeatedly installing the driver using the following command:

yum install akmod-nvidia xorg-x11-drv-nvidia-libs kernel-devel acpid

and then uninstalling using:

yum remove xorg-x11-drv-nvidia\*

Is there perhaps some package that I'm missing?

NVIDIA Driver Installation Failure on Fedora 20

I've been following all three of the following guides in order to to install the NVIDIA drivers on Fedora 20:

http://rpmfusion.org/Howto/nVidia http://www.if-not-true-then-false.com/2014/fedora-20-nvidia-guide/ https://ask.fedoraproject.org/en/question/10603/f18-how-to-install-nvidia-drivers/

All three basically say the same thing, and I've previously had success with these guides, but the GNOME display driver fails to start up on my newer machine.

I'm not sure if it makes a difference, but I'm using a Geforce 970 card.

I've been repeatedly installing the driver using the following command:

yum install akmod-nvidia xorg-x11-drv-nvidia-libs kernel-devel acpid

and then uninstalling using:

yum remove xorg-x11-drv-nvidia\*

Is there perhaps some package that I'm missing?


[squirem@localhost ~]$ sudo yum erase *\nvidia\*
[sudo] password for squirem: 
Loaded plugins: langpacks, refresh-packagekit
No Match for argument: *nvidia*
No Packages marked for removal
[squirem@localhost ~]$ sudo yum install akmod-nvidia xorg-x11-drv-nvidia-libs
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia.x86_64 1:331.113-1.fc20 will be installed
--> Processing Dependency: nvidia-kmod-common >= 1:331.113 for package: 1:akmod-nvidia-331.113-1.fc20.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:331.113-1.fc20 will be installed
--> Running transaction check
---> Package xorg-x11-drv-nvidia.x86_64 1:331.113-1.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================
 Package                               Arch                Version                       Repository                              Size
======================================================================================================================================
Installing:
 akmod-nvidia                          x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates               10 M
 xorg-x11-drv-nvidia-libs              x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates               24 M
Installing for dependencies:
 xorg-x11-drv-nvidia                   x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates              3.6 M

Transaction Summary
======================================================================================================================================
Install  2 Packages (+1 Dependent package)

Total download size: 38 M
Installed size: 131 M
Is this ok [y/d/N]: y
Downloading packages:
(1/3): xorg-x11-drv-nvidia-331.113-1.fc20.x86_64.rpm                                                           | 3.6 MB  00:00:02     
(2/3): akmod-nvidia-331.113-1.fc20.x86_64.rpm                                                                  |  10 MB  00:00:08     
(3/3): xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64.rpm                                                      |  24 MB  00:00:44     
--------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                 873 kB/s |  38 MB  00:00:44     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : 1:xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64                                                                   1/3 
  Installing : 1:akmod-nvidia-331.113-1.fc20.x86_64                                                                               2/3 
  Installing : 1:xorg-x11-drv-nvidia-331.113-1.fc20.x86_64                                                                        3/3 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.17.7-200.fc20.x86_64
Found initrd image: /boot/initramfs-3.17.7-200.fc20.x86_64.img
Found linux image: /boot/vmlinuz-3.11.10-301.fc20.x86_64
Found initrd image: /boot/initramfs-3.11.10-301.fc20.x86_64.img
Found linux image: /boot/vmlinuz-0-rescue-a2283f01bec946fcbb79c1bf22891041
Found initrd image: /boot/initramfs-0-rescue-a2283f01bec946fcbb79c1bf22891041.img
done
  Verifying  : 1:xorg-x11-drv-nvidia-331.113-1.fc20.x86_64                                                                        1/3 
  Verifying  : 1:xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64                                                                   2/3 
  Verifying  : 1:akmod-nvidia-331.113-1.fc20.x86_64                                                                               3/3 

Installed:
  akmod-nvidia.x86_64 1:331.113-1.fc20                        xorg-x11-drv-nvidia-libs.x86_64 1:331.113-1.fc20                       

Dependency Installed:
  xorg-x11-drv-nvidia.x86_64 1:331.113-1.fc20                                                                                         

Complete!
[squirem@localhost ~]$ sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
[squirem@localhost ~]$ sudo dracut /boot/initramfs-$(uname -r).img $(uname -r)

NVIDIA Driver Installation Failure on Fedora 20

I've been following all three of the following guides in order to to install the NVIDIA drivers on Fedora 20:

http://rpmfusion.org/Howto/nVidia http://www.if-not-true-then-false.com/2014/fedora-20-nvidia-guide/ https://ask.fedoraproject.org/en/question/10603/f18-how-to-install-nvidia-drivers/

All three basically say the same thing, and I've previously had success with these guides, but the GNOME display driver fails to start up on my newer machine.

I'm not sure if it makes a difference, but I'm using a Geforce 970 card.

I've been repeatedly installing the driver using the following command:

yum install akmod-nvidia xorg-x11-drv-nvidia-libs kernel-devel acpid

and then uninstalling using:

yum remove xorg-x11-drv-nvidia\*

Is there perhaps some package that I'm missing?


[squirem@localhost ~]$ sudo yum erase *\nvidia\*
[sudo] password for squirem: 
Loaded plugins: langpacks, refresh-packagekit
No Match for argument: *nvidia*
No Packages marked for removal
[squirem@localhost ~]$ sudo yum install akmod-nvidia xorg-x11-drv-nvidia-libs
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia.x86_64 1:331.113-1.fc20 will be installed
--> Processing Dependency: nvidia-kmod-common >= 1:331.113 for package: 1:akmod-nvidia-331.113-1.fc20.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:331.113-1.fc20 will be installed
--> Running transaction check
---> Package xorg-x11-drv-nvidia.x86_64 1:331.113-1.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================
 Package                               Arch                Version                       Repository                              Size
======================================================================================================================================
Installing:
 akmod-nvidia                          x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates               10 M
 xorg-x11-drv-nvidia-libs              x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates               24 M
Installing for dependencies:
 xorg-x11-drv-nvidia                   x86_64              1:331.113-1.fc20              rpmfusion-nonfree-updates              3.6 M

Transaction Summary
======================================================================================================================================
Install  2 Packages (+1 Dependent package)

Total download size: 38 M
Installed size: 131 M
Is this ok [y/d/N]: y
Downloading packages:
(1/3): xorg-x11-drv-nvidia-331.113-1.fc20.x86_64.rpm                                                           | 3.6 MB  00:00:02     
(2/3): akmod-nvidia-331.113-1.fc20.x86_64.rpm                                                                  |  10 MB  00:00:08     
(3/3): xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64.rpm                                                      |  24 MB  00:00:44     
--------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                 873 kB/s |  38 MB  00:00:44     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : 1:xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64                                                                   1/3 
  Installing : 1:akmod-nvidia-331.113-1.fc20.x86_64                                                                               2/3 
  Installing : 1:xorg-x11-drv-nvidia-331.113-1.fc20.x86_64                                                                        3/3 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.17.7-200.fc20.x86_64
Found initrd image: /boot/initramfs-3.17.7-200.fc20.x86_64.img
Found linux image: /boot/vmlinuz-3.11.10-301.fc20.x86_64
Found initrd image: /boot/initramfs-3.11.10-301.fc20.x86_64.img
Found linux image: /boot/vmlinuz-0-rescue-a2283f01bec946fcbb79c1bf22891041
Found initrd image: /boot/initramfs-0-rescue-a2283f01bec946fcbb79c1bf22891041.img
done
  Verifying  : 1:xorg-x11-drv-nvidia-331.113-1.fc20.x86_64                                                                        1/3 
  Verifying  : 1:xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64                                                                   2/3 
  Verifying  : 1:akmod-nvidia-331.113-1.fc20.x86_64                                                                               3/3 

Installed:
  akmod-nvidia.x86_64 1:331.113-1.fc20                        xorg-x11-drv-nvidia-libs.x86_64 1:331.113-1.fc20                       

Dependency Installed:
  xorg-x11-drv-nvidia.x86_64 1:331.113-1.fc20                                                                                         

Complete!
[squirem@localhost ~]$ sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
[squirem@localhost ~]$ sudo dracut /boot/initramfs-$(uname -r).img $(uname -r)

Extra Information:

[squirem@localhost ~]$ rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.2.2-1.fc20.x86_64
akmod-nvidia-331.113-1.fc20.x86_64
kernel-3.11.10-301.fc20.x86_64
kernel-3.17.7-200.fc20.x86_64
kernel-devel-3.17.7-200.fc20.x86_64
kernel-headers-3.17.7-200.fc20.x86_64
kernel-modules-extra-3.11.10-301.fc20.x86_64
kernel-modules-extra-3.17.7-200.fc20.x86_64
kmod-nvidia-3.17.7-200.fc20.x86_64-331.113-1.fc20.x86_64
libreport-plugin-kerneloops-2.2.3-2.fc20.x86_64
xorg-x11-drv-nvidia-331.113-1.fc20.x86_64
xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64
3.17.7-200.fc20.x86_64
nouveau              1312633  0 
i2c_algo_bit           13257  1 nouveau
ttm                    80807  1 nouveau
drm_kms_helper         89555  1 nouveau
drm                   296901  3 ttm,drm_kms_helper,nouveau
mxm_wmi                12865  1 nouveau
wmi                    18820  3 mxm_wmi,nouveau,asus_wmi
video                  19825  2 nouveau,asus_wmi
# RPM Fusion - nvidia-xorg.conf
# 
Section "Device"
    Identifier  "Videocard0"
    Driver      "nvidia"
EndSection
[squirem@localhost ~]$ lspci |grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)