Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Intel wireless chipset + ipv6 = no google

I have a Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0 freshly installed in an Intel nuc. I also have a dual-stack network with IPv4 and IPv6 running. The dual-stack has been problem-free for years.

All Google properties are slow to load and often fail. Everything else (IPv4) works fine, and simple stuff like pinging v6 addresses works fine. If I disable ipv6 with sysctl net.ipv6.conf.wlp2s0.disable_ipv6=1, Google properties work fine.

Circumstantially, it looks like this wireless chipset doesn't work well with the IPv6 traffic to Google. It's likely that Google is the only site with which I have a lot of v6 communication.

I don't see anything suspicious in the kernel logs, although my notion of "suspsicious" may not be very well-developed. I've tried setting the iwlwifi swcrypto=1 and 11n_disable=1 options, with no success. I've tried dialing back the interface MTU, also without effect.

I'm not sure how to continue debugging this.