Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Why did my games stop working after installing the nVidia drivers?

Hello! Previously I could not run Gnome Fedora in my PC because after installation (and many times during it) I would experience severe graphic glitches. Most of the time it would freeze in the easiest tasks and fill the screen with glitched patterns. I tried many versions and eventually I gave up on fedora since in the best case scenario I could surf the web and all the "a" "w" and "q"s would all disappear making any text incomprehensible.

When fedora 20 came out I really wanted to have it, but I had the very same problems when installing the gnome version. Eventually I realized it was probably the motherboard's built-in graphic processor that was incapable of the job, so I installed a GeForce 8400 GS that I had sitting around and VOILA! Fedora 20 was up and running with 0 problems! I was happy as I could be! Eventually I downloaded a nice 3D game to check it's performance and I was amazed it would run. (It used to run much smoother on Windows on this card but it didn't seem like anything to be worried about) I went on and installed Steam to play Monaco, and surprisingly enough, that was playable as well.

However under Details on Graphics it would read Gallium x.x (I can't recall the exact number). I figured that was because I had not yet installed the nVidia driver so I went on and did so hoping that it would maximize my systems performance. After the installation of the driver it now reads: GeForce 8400 GS/PCIe/SSE2. But! Now the little 3D game I had installed doesn't run anymore. A window pops up and immediately closes itself without any error prompting. Monaco does not run either flashing a white box and closing sortly after. The only error showing up seems to be an error about GL not being set in direct rendering mode.

Why did my games stop working after installing the nVidia drivers?

Hello! Previously I could not run Gnome Fedora in my PC because after installation (and many times during it) I would experience severe graphic glitches. Most of the time it would freeze in the easiest tasks and fill the screen with glitched patterns. I tried many versions and eventually I gave up on fedora since in the best case scenario I could surf the web and all the "a" "w" and "q"s would all disappear making any text incomprehensible.

When fedora 20 came out I really wanted to have it, but I had the very same problems when installing the gnome version. Eventually I realized it was probably the motherboard's built-in graphic processor that was incapable of the job, so I installed a GeForce 8400 GS that I had sitting around and VOILA! Fedora 20 was up and running with 0 problems! I was happy as I could be! Eventually I downloaded a nice 3D game to check it's performance and I was amazed it would run. (It used to run much smoother on Windows on this card but it didn't seem like anything to be worried about) I went on and installed Steam to play Monaco, and surprisingly enough, that was playable as well.

However under Details on Graphics it would read Gallium x.x (I can't recall the exact number). I figured that was because I had not yet installed the nVidia driver so I went on and did so hoping that it would maximize my systems performance. After the installation of the driver it now reads: GeForce 8400 GS/PCIe/SSE2. But! Now the little 3D game I had installed doesn't run anymore. A window pops up and immediately closes itself without any error prompting. Monaco does not run either flashing a white box and closing sortly after. The only error showing up seems to be an error about GL not being set in direct rendering mode.