Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

Since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard. How can I manage this? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

Since As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. But how? In the xorg.conf is no entry about it, that I could change. It seems that since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard. How can I manage this? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

The problem is that I have to enter this command after every reboot. Is there any possiblity to make this permanent? But how? In the xorg.conf (named: /etc/X11/xorg.conf.d/00-keyboard.conf) is no entry about it, that I could change. It seems that since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard. How can I manage this? keyboard.

Any suggestions? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

The problem is that I have to enter this command after every reboot. Is there any possiblity to make this permanent? But how? In the xorg.conf (named: /etc/X11/xorg.conf.d/00-keyboard.conf) is no entry about it, that I could change. It seems that since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard.

Any suggestions? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

The problem is that I have to enter this command after every reboot. Is there any possiblity to make this permanent? But how? In the xorg.conf (named: /etc/X11/xorg.conf.d/00-keyboard.conf) is no entry about it, that I could change. It seems that since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard.

Any suggestions? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

The problem is Thanks to Hello I got the advise to "add a shell script" to the "/etc/init.d (directory)" resp. /etc/rc.d/init.d/. No sooner said than done. I created with gedit a text file containing:

#!/bin/bash
xinput disable 10

and moved it to the designated folder.

But after restarting there was no difference. I still have to disable the touch screen manually. I assume that I have to enter this command after every reboot. Is there any possiblity to make this permanent? But how? In the xorg.conf (named: /etc/X11/xorg.conf.d/00-keyboard.conf) is no entry about it, that I could change. It seems that since Fedora 20, the xorg.conf file has lost weight and only controls the keyboard.the script isn't executed during the boot.

Any suggestions? suggestions what to do? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

Thanks to Hello I got the advise advice to "add a shell script" to the "/etc/init.d (directory)" resp. /etc/rc.d/init.d/. No sooner said than done. I created with gedit a text file containing:

#!/bin/bash
xinput disable 10

and moved it to the designated folder.

But after restarting there was no difference. I still have to disable the touch screen manually. I assume that the script isn't executed during the boot.

Any suggestions what to do? do next? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id>

But I have had to enter this command after every reboot. So a permanent solution has been necessary. Thanks to Hello I got the advice to "add a shell script" to the "/etc/init.d (directory)" resp. /etc/rc.d/init.d/. No sooner said than done. I created with gedit a text file containing:

#!/bin/bash
xinput disable 10

and moved it to the designated folder.

But after restarting there was no difference. I still have to disable the touch screen manually. I assume that the script isn't executed during the boot.

Any suggestions what to do next? Please help!

How to disable touch screen?

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id> But I have had to enter this command after every reboot. So a permanent solution has been necessary. Thanks to Hello I got the advice to "add a shell script" to the "/etc/init.d (directory)" resp. /etc/rc.d/init.d/. No sooner said than done. I created with gedit a text file containing:

#!/bin/bash
xinput disable 10

and moved it to the designated folder.

But after restarting there was no difference. I still have to disable the touch screen manually. I assume that the script isn't executed during the boot.

Any suggestions what to do next? Please help!