Ask Your Question

Revision history [back]

Fedora 20 - KDE not starting up

Well, it's been a long time I have a look at KDE. So, I decided to install it too on my Fedora 20 GNOME edition, and have a look at where is KDE now. And I installed KDE using:

yum install @kde-desktop

After rebooting, I tried to login to KDE Plasma and then kde wallpaper comes along with fedora logo, then the hard disk icon, and it stops there. I waited for a long time, and it still not loading. See the following picture for a good idea of what I am saying.

only fedora logo and disk icon is displaying

Here is the relevant portion from journalctl

Mar 31 00:05:07 linux-master /etc/gdm/Xsession[1838]: startkde: Starting up...
Mar 31 00:05:35 linux-master systemd[1]: Starting Stop Read-Ahead Data Collection...
Mar 31 00:05:35 linux-master systemd[1]: Started Stop Read-Ahead Data Collection.
Mar 31 00:08:53 linux-master gdm-Xorg-:0[1304]: (II) AIGLX: Suspending AIGLX clients for VT switch
Mar 31 00:08:53 linux-master systemd[1]: Starting Getty on tty2...
Mar 31 00:08:53 linux-master systemd[1]: Started Getty on tty2.

As you can see, I waited for around 3 minutes before pressing Alt+Ctrl+F2 and rebooting system. Also, there is no logs to show any kind of error. I looked for the hidden file .xsession-errors in my home directory and it is not there. Itried KDE Plasma failsafe mode but that also not starting up. Hanging at disk loading icon.

So, my problem is: i don't get KDE starting up. Also, no logs to pinpoint to any reason for that. I expect any help to find the problem, atleast to find the logs and know what the error is. Right know all I can search on google is KDE not working or KDE not starting.