Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

kmod-nvidia update dependency problem

[root@heisenbug yang]# yum update 
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia.x86_64 1:331.38-6.fc20.4 will be updated
---> Package akmod-nvidia.x86_64 1:331.49-1.fc20.2 will be an update
--> Processing Dependency: nvidia-kmod-common >= 1:331.49 for package: 1:akmod-nvidia-331.49-1.fc20.2.x86_64
---> Package kmod-nvidia-3.13.4-200.fc20.x86_64.x86_64 1:331.38-6.fc20.4 will be updated
---> Package kmod-nvidia-3.13.4-200.fc20.x86_64.x86_64 1:331.49-1.fc20.2 will be an update
--> Processing Dependency: nvidia-kmod-common >= 1:331.49 for package: 1:kmod-nvidia-3.13.4-200.fc20.x86_64-331.49-1.fc20.2.x86_64
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.13.4-200.fc20.x86_64-331.49-1.fc20.2.x86_64 (rpmfusion-nonfree-updates)
           Requires: nvidia-kmod-common >= 1:331.49
           Installed: 1:xorg-x11-drv-nvidia-331.38-1.fc20.x86_64 (@rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.38
           Available: 1:xorg-x11-drv-nvidia-331.20-6.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:331.20
           Available: 1:xorg-x11-drv-nvidia-331.20-7.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.20
           Available: xorg-x11-drv-nvidia-304xx-304.117-1.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.117-4.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.119-1.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.119-1001
Error: Package: 1:akmod-nvidia-331.49-1.fc20.2.x86_64 (rpmfusion-nonfree-updates)
           Requires: nvidia-kmod-common >= 1:331.49
           Installed: 1:xorg-x11-drv-nvidia-331.38-1.fc20.x86_64 (@rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.38
           Available: 1:xorg-x11-drv-nvidia-331.20-6.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:331.20
           Available: 1:xorg-x11-drv-nvidia-331.20-7.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.20
           Available: xorg-x11-drv-nvidia-304xx-304.117-1.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.117-4.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.119-1.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.119-1001
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Is it my problem or a bug?

kmod-nvidia update dependency problem

[root@heisenbug yang]# yum update 
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia.x86_64 1:331.38-6.fc20.4 will be updated
---> Package akmod-nvidia.x86_64 1:331.49-1.fc20.2 will be an update
--> Processing Dependency: nvidia-kmod-common >= 1:331.49 for package: 1:akmod-nvidia-331.49-1.fc20.2.x86_64
---> Package kmod-nvidia-3.13.4-200.fc20.x86_64.x86_64 1:331.38-6.fc20.4 will be updated
---> Package kmod-nvidia-3.13.4-200.fc20.x86_64.x86_64 1:331.49-1.fc20.2 will be an update
--> Processing Dependency: nvidia-kmod-common >= 1:331.49 for package: 1:kmod-nvidia-3.13.4-200.fc20.x86_64-331.49-1.fc20.2.x86_64
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.13.4-200.fc20.x86_64-331.49-1.fc20.2.x86_64 (rpmfusion-nonfree-updates)
           Requires: nvidia-kmod-common >= 1:331.49
           Installed: 1:xorg-x11-drv-nvidia-331.38-1.fc20.x86_64 (@rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.38
           Available: 1:xorg-x11-drv-nvidia-331.20-6.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:331.20
           Available: 1:xorg-x11-drv-nvidia-331.20-7.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.20
           Available: xorg-x11-drv-nvidia-304xx-304.117-1.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.117-4.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.119-1.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.119-1001
Error: Package: 1:akmod-nvidia-331.49-1.fc20.2.x86_64 (rpmfusion-nonfree-updates)
           Requires: nvidia-kmod-common >= 1:331.49
           Installed: 1:xorg-x11-drv-nvidia-331.38-1.fc20.x86_64 (@rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.38
           Available: 1:xorg-x11-drv-nvidia-331.20-6.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:331.20
           Available: 1:xorg-x11-drv-nvidia-331.20-7.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:331.20
           Available: xorg-x11-drv-nvidia-304xx-304.117-1.fc20.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.117-4.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.117-1001
           Available: xorg-x11-drv-nvidia-304xx-304.119-1.fc20.x86_64 (rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:304.119-1001
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Is it my problem or a bug?