Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Cant install some packages yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

tried

yum update yum reinstall *

with no effect anything else I can try to fix this ?

the error message:

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgcrypt which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgcrypt of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgcrypt.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgcrypt installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgcrypt installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

Cant install some packages yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

tried

yum update update

yum reinstall *

with no effect anything else I can try to fix this ?

the error message:

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgcrypt which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgcrypt of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgcrypt.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgcrypt installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgcrypt installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

Cant install some packages yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

tried

yum update

yum reinstall *

with With no effect effect. anything else I can try to fix this ?

the error message:

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgcrypt which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgcrypt of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgcrypt.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgcrypt installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgcrypt installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

Cant Can't install some packages - yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

tried

yum update

yum reinstall *

With no effect. anything else I can try to fix this ?

the error message:

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgcrypt which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgcrypt of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgcrypt.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgcrypt installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgcrypt installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

[SOLVED] Can't install some packages - yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

tried

yum update

yum reinstall *

With no effect. anything else I can try to fix this ?

the error message:

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgcrypt which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgcrypt of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgcrypt.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgcrypt installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgcrypt installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).
click to hide/show revision 6
No.6 Revision

[SOLVED] Can't install some packages - yum fails with Multilib error

I have tried to install playonlinux, and pipelight-plugin in both cases received the error below

below. I tried

yum update

and
yum reinstall *

With no effect. anything else I can try to fix this ?

the error message:

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

Eg.:

         1. You have an upgrade for libgcrypt which is missing some
         dependency that another package requires. Yum is trying to
         solve this by installing an older version of libgcrypt of the
         different architecture. If you exclude the bad architecture
         yum will tell you what the root cause is (which package
         requires what). You can try redoing the upgrade with
         --exclude libgcrypt.otherarch ... this should give you an error
         message showing the root cause of the problem.

      2. You have multiple architectures of libgcrypt installed, but
         yum can only see an upgrade for one of those architectures.
         If you don't want/need both architectures anymore then you
         can remove the one with the missing update and everything
         will work.

      3. You have duplicate versions of libgcrypt installed already.
         You can use "yum check" to get yum show these errors.

    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).