Ask Your Question

Revision history [back]

git clone with ssh hangs indefinitely with Fedora 29

I asked this question on Stack Overflow but haven't had any luck so far.

I'm running Fedora 29 and have properly added my .ssh key to GitHub. I know that Fedora runs a firewall by default, which I tried to disable by setting SELINUX=disabled in /etc/sysconfig/selinux.

After adding my key and configuring the firewall settings it should be fairly straight forward to clone, right? After an unusually long amount of time the process breaks with the following output:

[aaron@localhost repos]# git clone
Cloning into 'repo'...
Warning: Permanently added the RSA host key for IP address '' to the list of known hosts.
Connection to closed by remote host.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

The org and the repo both exist, and I am accessing them in the exact same way on other machines. In fact, for awhile, I was able to use GitKraken successfully on my machine to read and write from this repo, even while the command line wasn't working, which is very strange. This hack no longer works, either.

I've tried to debug with verbose output, but it just hangs here:

[aaron@localhost repos]$ git clone --progress --verbose
Cloning into 'repo'...

I also ran ssh -vT Here is the output. Looks like authentication into GitHub is successful and I'm able to authenticate into an interactive session, but then the process hangs:

debug1: Offering public key: /home/aaron/.ssh/id_rsa RSA SHA256:Gam7duBv/+8VMiJH1iEYrPX5UojI09D9nlRiXpNdyjg agent
debug1: Server accepts key: /home/aaron/.ssh/id_rsa RSA SHA256:Gam7duBv/+8VMiJH1iEYrPX5UojI09D9nlRiXpNdyjg agent
debug1: Authentication succeeded (publickey).
Authenticated to ([]:22).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: pledge: network
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug1: Sending env XMODIFIERS = @im=ibus
debug1: channel 0: free: client-session, nchannels 1
Connection to closed by remote host.
Transferred: sent 3508, received 2312 bytes, in 600.1 seconds
Bytes per second: sent 5.8, received 3.9
debug1: Exit status -1

Any thoughts?