Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How can I bypass /home/.bashrc so I can fix a mistake in it?

I have Fedora 28 installed. The only username is 'vm' and this user has root privileges (or at least I can run sudo). I was trying to alter my .bashrc script to make changes to a drive's permissions and unwisely used sudo setfacl -b /media/run/vm Now when it boots, I get to login as usual, but then it all goes to a black screen and I never can move beyond this. If I hit the power button to trigger shutdown, the screen flashes with a prompt for the password for the sudo command followed by the text that it is shutting down. There is no opportunity to enter the password.

I've tried Ctrl-C and just typing the password in on the black screen, but nothing gets me past this point.

I've tried to read about emergency modes and other boot options, but it always just seems to hang for several minutes on the white fedora logo when I try to boot this way. Should I just be more patient?

I tried logging in as 'root', but it doesn't accept the password for 'vm' and it doesn't accept a blank password. The company that set up my box did not send me a Fedora boot CD that I know of. I don't know if 'root' has a password that would get me past the .bashrc problem.

Anyway, I'm really stuck and would appreciate advice on how to get the system to a point where I can remove the sudo lines from the .bashrc file and be able to start up the thing again.