Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Udev mounted USB HD cannot write special characters

After upgrading to F29, I noticed I was getting errors on backups to external USB Hard Drive. At first I thought it was an issue with rsync. Then I discovered that the USB HD filenames would not accept special chars like ? and : Looking at /etc/mtab, I see the HD mount options as shown below.

/dev/sdb1 /run/media/estrauch/FantomHD fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

If I knew how to add mount option, iocharset=ascii, that would fix the problem. But digging into udev rules is a little beyond me.

Any ideas?