Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 29: Nvidia driver broken with 4.20 kernel

Since updating to the 4.20 kernel the nvidia driver appears to be broken - compiler error. I have the NVS 300 nvidia card with the 340.107 driver.

I did a 'dnf update' and now all kernels 4.20 and older are broken. At the point where it should display the login screen I get the 'Oops something went wrong...' dialog.

I guess I have to revert to nouveau driver?

Is there a way to prevent 'dnf update' from going past a particular kernel version?

The last version of the 340.107 driver is July 2018. Is Nvidia likely to release a patch for this, or am I am stuck at a pre-4.20 kernel?