Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Grub 2 display issue

Hello friends,

I have recently installed Fedora 29 workstation. I am running a dual boot system (Windows 10 and Fedora). After my installation, I installed the Nvidia proprietary drivers using this link. However, after I completed the install and rebooted, I noticed that my splash screen had reverted to the text theme. I tried to fix it but nothing worked. It was then that I ran the command videoinfo during boot in the grub command terminal. To my surprise the grub responded by saying "Can't find command videoinfo". I tried to run vbeinfo but it also had the same output.

It isn't the first time that I have worked on a linux. Some time back I used to use Ubuntu and everything was fine with the grub. I don't know what is the issue exactly. I have tried everything but neither does the grub resolution change nor does the splash recover. Below is my grub config file contents -

GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
#GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

GRUB_GFXPAYLOAD_LINUX="keep"
GRUB_VIDEO_BACKEND="efi_gop"
GRUB_TERMINAL_OUTPUT=gfxterm
#GRUB_FONT_PATH="/boot/efi/EFI/fedora/fonts/unicode.pf2"
GRUB_GFXMODE="1920x1080"

Can someone please tell me that why am I unable to change my grub resolution so that I am able to fix my splash screen? Also, what is more concerning to me is why does the grub not understand the commands videoinfo and vbeinfo? Could anyone please help me to resolve this issue for me.

Note: Secure boot is disabled and my OS is running on efi system

Thanking you all in anticipation.