Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't update hplip

First it was glibc not getting updated (still not solved: https://ask.fedoraproject.org/en/question/130579/cant-update-glibc/ ). Now hplip and related packages have a problem with a missing dependency version.

libnetsnmp.so.35()(64bit) is required, but the package net-snmp-libs currently provides libnetsnmp.so.30()(64bit).

This is all still on Fedora 28. What's going on with so many broken updates lately?

 Problem 1: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
 Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 3: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 4: package hplip-gui-3.18.6-11.fc28.x86_64 requires libsane-hpaio(x86-64) = 3.18.6-11.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package hplip-gui-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 5: cannot install both glibc-headers-2.27-35.fc28.x86_64 and glibc-headers-2.27-32.fc28.x86_64
  - glibc-headers-2.27-32.fc28.i686 has inferior architecture
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.x86_64
  - problem with installed package glibc-headers-2.27-32.fc28.i686
 Problem 6: package hplip-libs-3.18.6-10.fc28.x86_64 requires hplip-common(x86-64) = 3.18.6-10.fc28, but none of the providers can be installed
  - cannot install both hplip-common-3.18.6-11.fc28.x86_64 and hplip-common-3.18.6-10.fc28.x86_64
  - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
  - cannot install the best update candidate for package hplip-common-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 7: package glibc-headers-2.27-32.fc28.i686 requires glibc = 2.27-32.fc28, but none of the providers can be installed
  - cannot install both glibc-2.27-35.fc28.i686 and glibc-2.27-32.fc28.i686
  - cannot install both glibc-2.27-35.fc28.x86_64 and glibc-2.27-32.fc28.x86_64
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.x86_64
================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 glibc                i686          2.27-35.fc28           updates        3.4 M
 glibc                x86_64        2.27-35.fc28           updates        3.6 M
 glibc-headers        x86_64        2.27-35.fc28           updates        460 k
 hplip-common         x86_64        3.18.6-11.fc28         updates        110 k
Skipping packages with broken dependencies:
 hplip                x86_64        3.18.6-11.fc28         updates         16 M
 hplip-gui            x86_64        3.18.6-11.fc28         updates        1.3 M
 hplip-libs           x86_64        3.18.6-11.fc28         updates        204 k
 libsane-hpaio        x86_64        3.18.6-11.fc28         updates        127 k

Transaction Summary
================================================================================
Skip  8 Packages

Nothing to do.
Complete!

At least I can be thankful that the updates are skipped, instead of installing and borking my system.

Can't update hplip

EDIT: This issue is now resolved with the update to hplip version 3.18.6-12.fc28.


First it was glibc not getting updated (still not solved: https://ask.fedoraproject.org/en/question/130579/cant-update-glibc/ ). Now hplip and related packages have a problem with a missing dependency version.

libnetsnmp.so.35()(64bit) is required, but the package net-snmp-libs currently provides libnetsnmp.so.30()(64bit).

This is all still on Fedora 28. What's going on with so many broken updates lately?

 Problem 1: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
 Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 3: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 4: package hplip-gui-3.18.6-11.fc28.x86_64 requires libsane-hpaio(x86-64) = 3.18.6-11.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package hplip-gui-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 5: cannot install both glibc-headers-2.27-35.fc28.x86_64 and glibc-headers-2.27-32.fc28.x86_64
  - glibc-headers-2.27-32.fc28.i686 has inferior architecture
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.x86_64
  - problem with installed package glibc-headers-2.27-32.fc28.i686
 Problem 6: package hplip-libs-3.18.6-10.fc28.x86_64 requires hplip-common(x86-64) = 3.18.6-10.fc28, but none of the providers can be installed
  - cannot install both hplip-common-3.18.6-11.fc28.x86_64 and hplip-common-3.18.6-10.fc28.x86_64
  - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
  - cannot install the best update candidate for package hplip-common-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 7: package glibc-headers-2.27-32.fc28.i686 requires glibc = 2.27-32.fc28, but none of the providers can be installed
  - cannot install both glibc-2.27-35.fc28.i686 and glibc-2.27-32.fc28.i686
  - cannot install both glibc-2.27-35.fc28.x86_64 and glibc-2.27-32.fc28.x86_64
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.x86_64
================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 glibc                i686          2.27-35.fc28           updates        3.4 M
 glibc                x86_64        2.27-35.fc28           updates        3.6 M
 glibc-headers        x86_64        2.27-35.fc28           updates        460 k
 hplip-common         x86_64        3.18.6-11.fc28         updates        110 k
Skipping packages with broken dependencies:
 hplip                x86_64        3.18.6-11.fc28         updates         16 M
 hplip-gui            x86_64        3.18.6-11.fc28         updates        1.3 M
 hplip-libs           x86_64        3.18.6-11.fc28         updates        204 k
 libsane-hpaio        x86_64        3.18.6-11.fc28         updates        127 k

Transaction Summary
================================================================================
Skip  8 Packages

Nothing to do.
Complete!

At least I can be thankful that the updates are skipped, instead of installing and borking my system.