Ask Your Question

Revision history [back]

Ethernet connection deactivates after suspend (possible driver failure)

Hi, I was using F27, but when the EOL date approached, I upgraded to F29. I use KDE. Since about that time sometimes after the PC comes back after suspend, I see a message "Connection 'enp4s0f1' deactivated." and then it disappers from the list. I can still use WiFi. After a restart, it appears and works again. So I thought it was a driver problem and decided to find the driver for the eth adapter and restart it. I did

[root@localhost freeride]# lspci
...
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 14)

to find the driver coords; then

root@localhost freeride]# find /sys | grep drivers.*04:00
/sys/bus/pci/drivers/r8169/0000:04:00.1
/sys/bus/pci/drivers/rtsx_pci/0000:04:00.0

to find the driver(s) and then

[root@localhost freeride]# modprobe r8169

to restart the driver. However, nothing happens after that. The eth connection is still missing from the list. Any help? Thanks in advance.

Ethernet connection deactivates after suspend (possible driver failure)

Hi, I was using F27, F27 with KDE, but when the EOL date approached, I upgraded to F29. I use KDE. Since about that time sometimes after the PC comes back after suspend, I see a message "Connection 'enp4s0f1' deactivated." and then it disappers from the list. I can still use WiFi. After a restart, it appears and works again. So I thought it was a driver problem and decided to find the driver for the eth adapter and restart it. I did

[root@localhost freeride]# lspci
...
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 14)

to find the driver coords; then

root@localhost freeride]# find /sys | grep drivers.*04:00
/sys/bus/pci/drivers/r8169/0000:04:00.1
/sys/bus/pci/drivers/rtsx_pci/0000:04:00.0

to find the driver(s) and then

[root@localhost freeride]# modprobe r8169

to restart the driver. However, nothing happens after that. The eth connection is still missing from the list. Any help? help?

Thanks in advance.