Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't make nvidia proprietary driver work on Fedora 29

Hi,

I'm trying to install fedora on Dell XPS 15 9570 it has nVidia 1050 Ti graphics card. The Install goes smooth, the system boots using nouveau - but then freezes and overheats because of nouveau, so I'm disabling it on boot. Tried installing nvidia driver via rpm fusion and when that didn't work - through negativo17 - this also doesn't work.

The problem with proprietary nvidia driver from rpmfusion or negativo17 is that kernel module is not loaded (and manually doesn't load also), running modprobe nvidia returns "operation not permitted" error, which I read on Fedora docs is related to kernel module not for currently running kernel.

So.. Any suggestions on how to make nvidia proprietary work on new/clean Fedora 29 install? is it possible to install proprietary driver during installation of Fedora? Because nouveau really lock the system up upon first boot and I can't really do much using GNOME, I have to fallback to TTY..

And I would really like to make Fedora work for me.. Tried installing Manjaro 18.0 - worked out of the box with bumblebee and everything. Tried installing Ubuntu 18.10 - while it also had the issue of nouveu, at least I was able to make nvidia easily work using Ubuntu proprietary driver install upon first boot.