Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Install Fedora 28 on Lenovo Legion y530s

I am currently trying to install Fedora 28 on my brand new Lenovo Legion y530s. I currently have Windows 10 loaded, and am open to either a dual-boot environment, or strictly Fedora, whichever is easier at this point. My problem is that any time I try to install from live USB, Fedora does not detect any hard disk. I suspect this has something to do with my existing Windows 10 installation on a 1TB HDD + 25GB SSD (Intel Octane). I am guessing that my trouble is that Fedora may be recognizing my disks as RAID setup due to the Octane setup. I have tried:

Both Legacy BIOS and UEFI - Neither worked Changing from RST to AHCI mode Disabling Secure Boot Using Windows Disk Management to shrink the Windows partition - hoping that the free space would show up - no such luck when I left it unformatted or after formatting to NTFS Enabling and disabling Intel Virtual Technology (VM) - I can't imagine this has anything to do with it but I have tried it.

I have scoured the internet for the better part of the day, and can find no help to my issue. I am open to possibly a different distro than Fedora, but Fedora is BY FAR my most preferred distro. Any help would be greatly appreciated. Please let me know what other info you might need from me to help diagnose my issue.