Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin, I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso distribution I installed, the system started to download updates, I rebooted the system and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error "alloc magic broken", then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

Yesterday I added in the UEFI settings the grub2x64.efi (or something in that vain) file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc magic" message.

Please help.

PS cannot add the proper tags, it's obviously dual boot.

There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin, I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso distribution I installed, the system started to download updates, I rebooted the system and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error "alloc magic broken", then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

Yesterday I added in the UEFI settings the grub2x64.efi (or something in that vain) file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc magic" message.

Please help.

PS cannot add the proper tags, it's obviously dual boot.

There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin, I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso distribution I installed, the system started to download updates, I rebooted the system and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error "alloc magic broken", then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

Yesterday I added in the UEFI settings the grub2x64.efi (or something in that vain) file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc magic" message.

Please help.

There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to.

I filmed the boot so I could slow it down to show what happens when I launch the window boot manager, it says as follows: System BootOrder not found. Initializing defaults. Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin, diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso distribution iso-distribution I installed, the system started to download updates, I rebooted the system system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows "Windows Boot Manager, Manager", though, there is an error "alloc magic is broken", I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

Yesterday I added in the UEFI settings the grub2x64.efi (or something in that vain) file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc magic" message.

Please help.

There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to.

EDIT: I filmed the boot (booting "Windows Boot Manager" from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows: System BootOrder not found. Initializing defaults. Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

So when I issue "sudo efibootmgr" in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc magic is broken" message.

PS: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select "Windows Windows Boot Manager", Manager, though, there is an error "alloc alloc magic is broken", broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting "Windows Windows Boot Manager" Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows: follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

"\EFI\fedora\shimx64.efi"

So when I issue "sudo efibootmgr" sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the "alloc alloc magic is broken" broken message.

PS: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: PS1: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

PS2: I have now done what I said I could do in PS1. I installed Windows, re-imaged my disk (Windows installation) and then added in the firmware shimx64.efi back as an allowed executable file. This restored the dual boot and it worked a few (1 or 2) times switching between Windows and Fedora. It worked both from the F12 boot menu and from grub (both Fedora and Windows) But then alas, things broke again, back to where I was. So I'm starting to believe that @cmurf is correct in saying that the firmware is buggy. I will go to the procedure again (without actual dual booting) update the firmware and see how it goes. I'll report back.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS1: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

PS2: I have now done what I said I could do in PS1. I installed Windows, re-imaged my disk (Windows installation) and then added in the firmware shimx64.efi back as an allowed executable file. This restored the dual boot and it worked a few (1 or 2) times switching between Windows and Fedora. It worked both from the F12 boot menu and from grub (both Fedora and Windows) But then alas, things broke again, back to where I was. So I'm starting to believe that @cmurf is correct in saying that the firmware is buggy. I will go to the procedure again (without actual dual booting) update the firmware and see how it goes. I'll report back.

PS3: I did as per PS2, flashed the Firmware, tested the booting in both systems, works perfectly (both from Grub and F12), and then I did as per above the final step, re-image my system, and then it broke again. Now I have with almost 100% certainty, determined that the install media of Windows I install and the image (of the C:\ drive) I have are out if sync (version-wise) and possible one is en-US while the other one is en-UK. So downloading install-media.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS1: There's no problem getting Windows to work again, I could just do a quick install and then just replace that installation with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

PS2: I have now done what I said I could do in PS1. I installed Windows, re-imaged my disk (Windows installation) and then added in the firmware shimx64.efi back as an allowed executable file. This restored the dual boot and it worked a few (1 or 2) times switching between Windows and Fedora. It worked both from the F12 boot menu and from grub (both Fedora and Windows) But then alas, things broke again, back to where I was. So I'm starting to believe that @cmurf is correct in saying that the firmware is buggy. I will go to the procedure again (without actual dual booting) update the firmware and see how it goes. I'll report back.

PS3: I did as per PS2, flashed the Firmware, tested the booting in both systems, works perfectly (both from Grub and F12), and then I did as per above the final step, re-image my system, and then it broke again. Now I have with almost 100% certainty, determined that the install media of Windows I install and the image (of the C:\ drive) I have are out if sync (version-wise) and possible one is en-US while the other one is en-UK. So downloading install-media.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS1: There's no problem getting PS: Summarizing and concluding. The issue I was seeing is caused by running BestCrypt Volume Encryption on my Windows to work again, I could just do a quick install and then just replace that installation system, the software changes the default way Windows boot works and then obviously breaks whatever Fedora assumes. Jetico (BCVE) does not provide a Linux version, so I'll be switching to VeraCrypt (ported to all relevant systems). I've already installed VeraCrypt on Fedora, but I'll hold of till version 1.23 comes out (which should have been 2 days ago) as the release notes show many fixes and improvements, particularly in the area of EFI boot matters. VeraCrypt will (apparently) also mess with an image of my system proper. The problem is then of course that I will have lost the possibility to boot into fedora again, which I don't want to. In the meanwhile I had lots of opportunity to actually have a look at Fedora, and I think I'm gonna love it, it's got gcc-8.1 as default, I did not expect that f.e., I also am able to connect my BlueTooth headphones and mouse to work, well, I would say.

PS2: I have now done what I said I could do in PS1. I installed Windows, re-imaged my disk (Windows installation) and then added in the firmware shimx64.efi back as an allowed executable file. This restored the dual boot and it worked a few (1 or 2) times switching between Windows and Fedora. It worked both from the F12 boot menu and from grub (both Fedora and Windows) But then alas, things broke again, back to where I was. So I'm starting to believe that @cmurf is correct in saying that the firmware is buggy. I will go to the procedure again (without actual dual booting) update the firmware and the boot process, I'll see how it goes. I'll report back.

PS3: I did that goes.

I would particularly like to thank @cmurf for looking at lots of spaghetti on the wall as per PS2, flashed the Firmware, tested the booting in both systems, works perfectly (both from Grub and F12), and then I did as per above the final step, re-image my system, and then it broke again. Now I have with almost 100% certainty, determined that the install media of Windows I install and the image (of the C:\ drive) I have are out if sync (version-wise) and possible one is en-US while the other one is en-UK. So downloading install-media.he calls it! Thank.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: Summarizing and concluding. The issue I was seeing is caused by running BestCrypt Volume Encryption on my Windows system, the software changes the default way Windows boot works and then obviously breaks whatever Fedora assumes. Jetico (BCVE) does not provide a Linux version, so I'll be switching to VeraCrypt (ported to all relevant systems). I've already installed VeraCrypt on Fedora, but I'll hold of till version 1.23 comes out (which should have been 2 days ago) as the release notes show many fixes and improvements, particularly in the area of EFI boot matters. VeraCrypt will (apparently) also mess with the boot process, I'll see how that goes.

I would particularly like to thank @cmurf for looking at lots of spaghetti on the wall as he calls it! Thank.Thanks.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: Summarizing and concluding. The issue I was seeing is caused by running BestCrypt Volume Encryption on my Windows system, the software changes the default way Windows boot works and then obviously breaks whatever Fedora assumes. Jetico (BCVE) does not provide a Linux version, so I'll be switching to VeraCrypt (ported to all relevant systems). I've already installed VeraCrypt on Fedora, but I'll hold of till version 1.23 comes out (which should ~~should have been 2 days ago) ago~~ has now, 13.09.2018, been released) as the release notes show many fixes and improvements, particularly in the area of EFI boot matters. VeraCrypt will (apparently) also mess with the boot process, I'll see how that goes.

I would particularly like to thank @cmurf for looking at lots of spaghetti on the wall as he calls it! Thanks.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: Summarizing and concluding. The issue I was seeing is caused by running BestCrypt Volume Encryption on my Windows system, the software changes the default way Windows boot works and then obviously breaks whatever Fedora assumes. Jetico (BCVE) does not provide a Linux version, so I'll be switching to VeraCrypt (ported to all relevant systems). I've already installed VeraCrypt on Fedora, but I'll hold of till version 1.23 comes out (which ~~should have been 2 days ago~~ has now, 13.09.2018, been released) as the release notes show many fixes and improvements, particularly in the area of EFI boot matters. matters.

Fast-forward: I've uninstalled (removed) Jetico's BestCrypt Volume Encryption (from Windows) and much to my surprise, doing just that, restored everything into working order, Grub is fully functional. I did now also install VeraCrypt will (apparently) also mess with the boot process, I'll see how 1.23 on both Windows and Fedora and this software package preserves the dual-boot, no more issues, whatsoever. There is the obvious advantage that goes.now I can encrypt/decrypt and mount the same (encrypted) disk, both in Windows and in Fedora. I thought this was useful information, id. the update.

I would particularly like to thank @cmurf for looking at lots of spaghetti on the wall as he calls it! Thanks.

How to fix dual-boot after updates

I am new to Fedora/Linux/BSD, so please bear with me.

Yesterday, after installing Fedora and after lots of diggin', I was able to have a proper dual-boot system (so this is my second day with Fedora). Then as this was the iso-distribution I installed, the system started to download updates, I rebooted the system, this morning after the downloads were complete, and then my nicely working dual-boot was broken again. I can get into Fedora, I'm writing this on Fedora. When I select Windows Boot Manager, though, there is an error alloc magic is broken, I then push enter and then some more stuff shows up for a fraction of a second and then the system reboots, so I cannot read what that says.

EDIT: I filmed the boot (booting Windows Boot Manager from the F12 boot menu) so I could slow it down to show what happens when I launch the window boot manager, it says as follows:

System BootOrder not found. Initializing defaults.
Creating boot entry "Boot0028" with label "Fedora" for file "\EFI\fedora\shimx64.efi"

Reset System

So when I issue sudo efibootmgr in a terminal, I have many entries, not just 3, 4 or 5 or so (who thought this was a good idea [to just keep creating new ones])? It seems all is related to some mis-configuration of efibootmgr (grub2).

Yesterday, I added in the UEFI settings the grubx64.efi file as allowed, that did the trick. But then when I rebooted after the updates this morning, the system complained that shimx64.efi (what does this .efi do?) was missing (i.e. not allowed), so I added that, that did again the trick (Fedora worked again), but windows does not boot with the alloc magic is broken message.

PS: Summarizing and concluding. The issue I was seeing is caused by running BestCrypt Volume Encryption on my Windows system, the software changes the default way Windows boot works and then obviously breaks whatever Fedora assumes. Jetico (BCVE) does not provide a Linux version, so I'll be switching to VeraCrypt (ported to all relevant systems). I've already installed VeraCrypt on Fedora, but I'll hold of till version 1.23 comes out (which has now, 13.09.2018, been released) as the release notes show many fixes and improvements, particularly in the area of EFI boot matters.

Fast-forward: I've uninstalled (removed) Jetico's BestCrypt Volume Encryption (from Windows) and much to my surprise, doing just that, restored everything into working order, Grub is fully functional. I did now also install VeraCrypt 1.23 on both Windows and Fedora and this software package preserves the dual-boot, no more issues, whatsoever. There is the obvious advantage that now I can encrypt/decrypt and mount the same (encrypted) disk, both in Windows and in Fedora. I thought this was useful information, id. the update.

I would particularly like to thank @cmurf for looking at lots of spaghetti on the wall as he calls it! Thanks.