Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

dnf.conf exclude does not work

Hi, I'm new to Fedora. My laptop has an nvidia quadro 4000M card that is compatible with the 390.x drivers from nvidia, but not with the newer 396.x. So, to have a working driver I disabled, the rpmfusion non free update repo and installed the nvidia drivers that are working well. After that, after some googling, I added an exclude command to both dnf.com and rpmfusion-nonfree-updates.repo, the latter to the enabled section. I even tried to use the excludepkgs command that I didn't understand if it is or not deprecated, but, if I enable back the rpmfusion non free update repo, the updater still asks me to update the nvidia driver, something that's really annoying. For instance, the string I added is: excludepkgs=xorg-x11-drv-nvidia* akmod-nvidia* xorg-x11-drv-nvidia-cuda* nvidia* I wonder if there's a way to override this behaviour, that to me looks like a bug. Thank you in advance for your help.