Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

v4l2loopback gstreamer1.0 /dev/video1 not output device

I am trying to use v4l2loopback and gstreamer to make my DSLR a webcam. I finally got all the needed libraries, to my knowledge, but now when I run

gphoto2 --capture-movie --stdout | gst-launch-1.0 videotestsrc ! v4l2sink device=/dev/video1

I get the following output:

Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Sink:v4l2sink0: Device '/dev/video1' is not a output device.
Additional debug info:
v4l2_calls.c(646): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Sink:v4l2sink0:
Capabilities: 0x4a00000
Setting pipeline to NULL ...
Freeing pipeline ...
Capturing preview frames as movie to 'stdout'. Press Ctrl-C to abort.

I have run this command multiple times, which is why it tries to pause the pipeline, but I don't think that it has anything to do with the problem. I am using Fedora 28 and I have gstreamer 0.10 and 1.0. I have tried using both the 0.10 and 1.0 gstreamer versions but with the same results. Also, where is "stdout' or the standard output for the pipeline?

I can view the camera's video with programs like entange and darktable, both designed for this, but they don't have any options to make the DSLR a webcam. I only mention this because it means that the camera and USB connections are working .