Ask Your Question

Revision history [back]

Troubleshooting setting up Wake-On-LAN

Hi everyone !

First of all, I'd like to say thank you for reading me and/or answering me ! So thanks to you ! :) It's actually my first post, but i'm used to search a lot on AskFedora (which helped me a lot) ! So I will try to give a lot of information to my problem.

And here we go, time for some details on my problem. I'm trying to set up a computer with dualboot (Win10 / Fedora28) to Wake-On-Lan with Magic Packets. So I first look at my BIOS Setup to find an option to enable like "PCI Power Up" or "Magic Packet" options. But I can't find it. I read on another forum (I don't remember which one, because of several reboot due to testing ...), during online search that somehow, my BIOS is set to have this option forced to be enable, so no entry in BIOS Setup. The thing is, that when i modify boot option in BIOS Setup to Windows Boot Loader, WOL works. But I want to WOL on my grub. So here come some information on my BIOS and motherboard :

Informations get with "sudo dmidecode -s [string]" command :

[string]    :   [output]
bios-vendor :   American Megatrends Inc.
bios-version    :   F22
baseboard-manufacturer  :   Gigabyte Technology Co., Ltd.
baseboard-product-name  :   Z170-Gaming K3-CF

Then I assumed that the problem comes from Grub or Fedora. But I didn't find anything about grub configuration for WOL. So I assumed the problem was due Fedora configuration. I tried to enable WoL on my Network Card enp3s0 with ethtool command. After here every MAC Address show is not the real MAC Address of my Network Card, but i did all my test with the right one. So the false one is 00:11:22:33:44:55.

Here some information on my network card enp3s0 get with ifconfig enp3s0 :

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 2a01:cb08:899b:ac00:3698:3f4e:2b6:52d6  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::211f:7fb4:5769:10a5  prefixlen 64  scopeid 0x20<link>
        ether 00:11:22:33:44:55  txqueuelen 1000  (Ethernet)
        RX packets 1393  bytes 149247 (145.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 332  bytes 35123 (34.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18

And here is the output of sudo ethtool -s enp3s0 wol g :

Cannot get current wake-on-lan settings: Operation not supported
  not setting wol

Then, I get these output with sudo ethtool enp3s0 :

Settings for enp3s0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Current message level: 0x000060e4 (24804)
                   link ifup rx_err tx_err hw wol
    Link detected: yes

So, after a few hours of online research, i find out that there is a GUI application to do it, which is nm-connection-editor. I use it in the purpose to modify the enp3s0 one and get this output without doing any change, so it is my configuration on enp3s0 I assumed (but maybe not ?) (I had to reproduce the picture to ASCII style because I'm a new user, and it's my first post) :

Device          :   enp3s0 (00:11:22:33:44:55)
Cloned MAC Address  :   (NONE)
MTU         :   automatic
Wake on LAN     :   Magic is ticked, every other checkable box is uncheck

After this I tried to Wake on LAN my computer, but it doesn't work. So I listened to the port receiving the Magic Packet on my computer to boot by WOL with nc command (let's call it PC1) while i sent it with another computer with wol command (let's call it PC2).

Here is what I get on PC1 with sudo nc --udp --listen -p 40000 -x ./test :

[0000]   FF FF FF FF FF FF 00 11   22 33 44 55 00 11 22 33   ........ .k.....k
[0010]   44 55 00 11 22 33 44 55   00 11 22 33 44 55 00 11   .....k.. ...k....
[0020]   22 33 44 55 00 11 22 33   44 55 00 11 22 33 44 55   .k.....k .....k..
[0030]   00 11 22 33 44 55 00 11   22 33 44 55 00 11 22 33   ...k.... .k.....k
[0040]   44 55 00 11 22 33 44 55   00 11 22 33 44 55 00 11   .....k.. ...k....
[0050]   22 33 44 55 00 11 22 33   44 55 00 11 22 33 44 55   .k.....k .....k..
[0060]   00 11 22 33 44 55                                   ...k..

Here is the output of wol --verbose 00:11:22:33:44:55 :

Waking up 00:11:22:33:44:55 with

Here we see the packet is sent and received, and is well-formed. And that's when i decided to come to you ! Because I don't understand why ethtool can't enable Magic Packet on enp3s0 and nm-connection-editor shows that Magic Packet are enable, and still I can't WOL my computer.

Here is uname -a output of my target computer if needed :

Linux squanchy-pc 4.17.3-200.fc28.x86_64 #1 SMP Tue Jun 26 14:17:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Again, big thanks to you for reading and/or answering me ! :)