Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't connect to my wifi after updating, Fedora 28 Live CD works

I have two Fedora 28 machines. One of them acts as a router which shares a mobile Internet connection by creating a new wifi network. The other machine can connect to the wifi network when I boot it into Fedora 28 Live CD (LXDE spin). I installed Fedora 28 to the hard disk and updated packages. After the update, the machine can't connect to my wifi any more!

The updated machine can connect to another wifi, but not to my wifi.

When I try to connect, dmesg says:

[2018-06-16 17:09:48]  wlp2s0b1: authenticate with 00:16:cf:6a:bd:ef
[2018-06-16 17:09:48]  wlp2s0b1: send auth to 00:16:cf:6a:bd:ef (try 1/3)
[2018-06-16 17:09:48]  wlp2s0b1: authenticated
[2018-06-16 17:09:48]  brcmsmac bcma0:1 wlp2s0b1: disabling HT as WMM/QoS is not supported by the AP
[2018-06-16 17:09:48]  brcmsmac bcma0:1 wlp2s0b1: disabling VHT as WMM/QoS is not supported by the AP
[2018-06-16 17:09:48]  wlp2s0b1: associate with 00:16:cf:6a:bd:ef (try 1/3)
[2018-06-16 17:09:48]  wlp2s0b1: RX AssocResp from 00:16:cf:6a:bd:ef (capab=0x411 status=30 aid=4)
[2018-06-16 17:09:48]  wlp2s0b1: 00:16:cf:6a:bd:ef rejected association temporarily; comeback duration 1000 TU (1024 ms)
[2018-06-16 17:09:49]  wlp2s0b1: associate with 00:16:cf:6a:bd:ef (try 2/3)
[2018-06-16 17:09:49]  wlp2s0b1: RX AssocResp from 00:16:cf:6a:bd:ef (capab=0x411 status=0 aid=4)
[2018-06-16 17:09:49]  brcmsmac bcma0:1: brcmsmac: brcms_ops_bss_info_changed: associated
[2018-06-16 17:09:49]  brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: true (implement)
[2018-06-16 17:09:49]  wlp2s0b1: associated
[2018-06-16 17:09:49]  wlp2s0b1: deauthenticating from 00:16:cf:6a:bd:ef by local choice (Reason: 1=UNSPECIFIED)
[2018-06-16 17:09:49]  brcmsmac bcma0:1: brcmsmac: brcms_ops_bss_info_changed: disassociated
[2018-06-16 17:09:49]  brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
[2018-06-16 17:09:49]  IPv6: ADDRCONF(NETDEV_UP): wlp2s0b1: link is not ready
[2018-06-16 17:09:50]  brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
[2018-06-16 17:09:50]  brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
[2018-06-16 17:09:50]  IPv6: ADDRCONF(NETDEV_UP): wlp2s0b1: link is not ready

On the machine which acts as a router I get this in /var/log/messages:

Jun 17 19:27:18 acer wpa_supplicant[760]: wlp4s5: AP-STA-CONNECTED 90:a4:de:77:ef:7d
Jun 17 19:27:19 acer wpa_supplicant[760]: ieee802_11_send_sa_query_req: send failed
Jun 17 19:27:20 acer wpa_supplicant[760]: ieee802_11_send_sa_query_req: send failed
Jun 17 19:27:20 acer wpa_supplicant[760]: ieee802_11_send_sa_query_req: send failed
Jun 17 19:27:20 acer wpa_supplicant[760]: ieee802_11_send_sa_query_req: send failed

I have several other machines which can connect to my wifi, including several Android devices.

The live CD has the following versions:

kernel-core-4.16.3-301.fc28.x86_64
wpa_supplicant-2.6-14.fc28.x86_64

Now I have updated to wpa_supplicant-2.6-15.fc28.x86_64. I tried booting with the old kernel (4.16.3-301) but it can't connect to my wifi either any more.

My wifi card is:

[root@localhost ~]# lspci -vnn -d 14e4:
02:00.0 Network controller [0280]: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
    Subsystem: Wistron NeWeb Corp. Device [185f:051a]
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f3200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Vendor Specific Information: Len=78 
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-de-ff-ff-77-90-a4
    Capabilities: [16c] Power Budgeting 
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma

I even tried to install akmod-wl as well. It can't connect to my wifi, dmesg shows:

[2018-06-17 16:31:11]  ERROR @wl_set_key_mgmt : 
[2018-06-17 16:31:11]  invalid cipher group (1027074)