Ask Your Question

Revision history [back]

failed to find a suitable stage1 device

When I try to install Fedora28 Workstation using a Flash Drive I get the error "failed to find a suitable stage1 device" when it tries to do automatic partitioning, I'm attempting to dual-boot Fedora with Windows 10. I gave Fedora 40 gbs of room to install, and 50 gb on another attempt. I was able to successfully install Fedora on a second device, a laptop with windows 7, perfectly fine using the same Flash Drive so the ISO isn't corrupted. I tried to install another Linux OS called Qubes OS which also used the anaconda installer on this device and I got the same error at the same part, though the Qubes OS ISO I later learned to be corrupted.

I do know this question has already gotten posted, but all the answers I could find on the internet either didn't work (E.G:One said that the error comes from not giving the OS enough space on the harddrive but I provided more than enough) or didn't explain how to fix it.