Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem with Radeon 7480D graphics

Ok, this one has been doing my nut for a few days now... I have a HTPC that sits under my main TV and runs everything from File server to kodi. Until now it has been running windows 7 but that recently encountered a windows update issue and died on me. As i've moved my laptop over to Fedora :) I thought i'd try and switch the HTPC and experiment with Docker for my server apps. BUT...

It simply won't boot after install. The live usb works fine and the install completes without issue but when I reboot I get the grub screen and then a reboot. This repeats for ever. I've tried several different distros and all are exactly the same.

As far as I can tell this is down to the kernal drivers for Radeon and AMDGPU. The 7480D (i'm using an AMD A4-4000 APU) isn't supported by the AMDGPU driver and needs the Radeon driver. If I set nomodeset it will boot but all I can get is 640x480. I've tried every combination of blacklist I can find online but the AMDGPU won't go away. I've tried the grub blacklist parameters and also adding to the blacklist.conf under /etc/modprobe.d

I really don't want to put windows 10 on this, please help.

Thanks