Ask Your Question

Revision history [back]

Upgrade issue: does not belong to a distupgrade repository

I am trying to upgrade to the Fedora 28 beta with dnf system-upgrade and it doesn't work. I'm used to problems where dnf gives suggestions. I've never had this error before and I think its new because I can't find much on Google. My system is completely up to date on the 27 branch.

Here is the output of # dnf system-upgrade download --refresh --releasever=28

Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Failed to synchronize cache for repo 'fedora-flash-plugin', disabling.
Failed to synchronize cache for repo 'fedora-multimedia', disabling.
Failed to synchronize cache for repo 'fedora-nvidia', disabling.
Failed to synchronize cache for repo 'fedora-spotify', disabling.
Failed to synchronize cache for repo 'fedora-steam', disabling.
Failed to synchronize cache for repo 'rpmfusion-free-updates', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-updates', disabling.
Last metadata expiration check: 0:00:00 ago on Fri 06 Apr 2018 15:24:38 AEST.
Error: 
 Problem 1: problem with installed package gstreamer1-plugins-ugly-1:1.12.3-2.fc27.x86_64
  - gstreamer1-plugins-ugly-1:1.12.3-2.fc27.x86_64 does not belong to a distupgrade repository
  - nothing provides gstreamer1-plugins-ugly-free(x86-64) = 1.14.0 needed by gstreamer1-plugins-ugly-1.14.0-1.fc28.x86_64
 Problem 2: package libnice-gstreamer-0.1.14-1.fc27.x86_64 requires libnice(x86-64) = 0.1.14-1.fc27, but none of the providers can be installed
  - libnice-0.1.14-1.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package libnice-gstreamer-0.1.14-1.fc27.x86_64
 Problem 3: nss-pem-1.0.3-6.fc27.i686 has inferior architecture
  - nss-pem-1.0.3-6.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-6.fc27.i686
 Problem 4: package vlc-core-3.0.1-5.fc28.x86_64 requires libliveMedia.so.62()(64bit), but none of the providers can be installed
  - problem with installed package vlc-core-1:3.0.0-23.20171025gita55b0a5.fc27.x86_64
  - installed package live555-libs-1:2017.09.12-1.fc27.x86_64 obsoletes live555 < 1:2016.03.14 provided by live555-2018.02.18-1.fc28.x86_64
  - vlc-core-1:3.0.0-23.20171025gita55b0a5.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package live555-libs-1:2017.09.12-1.fc27.x86_64