Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem during dnf-upgrade (f26 -->f27):

Hi, I am trying to upgrade my Fedora workstation from F26 to F27. When I order

$ sudo dnf system-upgrade download --refresh --releasever=27

I get the following dependency error:

 Problem 3: both package dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch and dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch obsolete yumex-dnf < 4.3.3-5
  - problem with installed package yumex-dnf-4.3.3-4.1.fc26.noarch
  - package dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch requires dnfdragora = 1.0.1-6.git20170505.2a3b056.fc27, but none of the providers can be installed
  - both package dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch and dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch obsolete yumex-dnf < 4.3.3-5
  - cannot install both dnfdragora-1.0.1-6.git20170505.2a3b056.fc27.noarch and dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch
  - yumex-dnf-4.3.3-4.1.fc26.noarch does not belong to a distupgrade repository

My problem(s): I am not brave enough to remove yumex-dnf since this wants the remove the following packages, which sound too important to me:

Removing dependent packages:
 dnfdaemon-selinux                                      noarch                                      0.3.18-5.fc26                                         @updates                                        0  
 python3-dnfdaemon                                      noarch                                      0.3.18-5.fc26                                         @updates                                       69 k
Entferne ungültige Abhängigkeiten:
 dnfdaemon                                              noarch                                      0.3.18-5.fc26                                         @updates                                      263 k

Can I just remove yumex-dnf? Will dnf continue to work afterwards?

Or can I upgrade to F27 and just skip the install process of dnfdragora? I don't think I need or want that package...

Any help is appreciated!

Problem during dnf-upgrade (f26 -->f27):

Hi, I am trying to upgrade my Fedora workstation from F26 to F27. When I order

$ sudo dnf system-upgrade download --refresh --releasever=27

I get the following dependency error:

 Problem 3: both package dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch and dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch obsolete yumex-dnf < 4.3.3-5
  - problem with installed package yumex-dnf-4.3.3-4.1.fc26.noarch
  - package dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch requires dnfdragora = 1.0.1-6.git20170505.2a3b056.fc27, but none of the providers can be installed
  - both package dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch and dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27.noarch obsolete yumex-dnf < 4.3.3-5
  - cannot install both dnfdragora-1.0.1-6.git20170505.2a3b056.fc27.noarch and dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch
  - yumex-dnf-4.3.3-4.1.fc26.noarch does not belong to a distupgrade repository

My problem(s): I am not brave enough to remove yumex-dnf since this wants the remove the following packages, which sound too important to me:

Removing dependent packages:
 dnfdaemon-selinux                                      noarch                                      0.3.18-5.fc26                                         @updates                                        0  
 python3-dnfdaemon                                      noarch                                      0.3.18-5.fc26                                         @updates                                       69 k
Entferne ungültige Abhängigkeiten:
 dnfdaemon                                              noarch                                      0.3.18-5.fc26                                         @updates                                      263 k

Can I just remove yumex-dnf? Will dnf continue to work afterwards?

Or can I upgrade to F27 and just skip the install process of dnfdragora? I don't think I need or want that package...

Any help is appreciated!