Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Installing VLC from rpmfusion fails with "not found"

Hi, I'm using fedora27 and have the rpmfusion repos installed:

$ ls -l *rpmfusion*
-rw-r--r-- 1 root root 1248 Nov 13 13:17 rpmfusion-free.repo
-rw-r--r-- 1 root root 1245 Nov 13 13:17 rpmfusion-free-updates.repo
-rw-r--r-- 1 root root 1305 Nov 13 13:17 rpmfusion-free-updates-testing.repo
-rw-r--r-- 1 root root 1293 Nov 13 13:21 rpmfusion-nonfree.repo
-rw-r--r-- 1 root root 1290 Nov 13 13:21 rpmfusion-nonfree-updates.repo
-rw-r--r-- 1 root root 1350 Nov 13 13:21 rpmfusion-nonfree-updates-testing.repo

However, installing or even searching for vlc fails:

# dnf search vlc
Fedora 27 - x86_64 - Updates                           7.0 MB/s |  19 MB     00:02
Fedora 27 - x86_64                                     6.8 MB/s |  58 MB     00:08
RPM Fusion for Fedora 27 - Free - Updates              2.8 MB/s | 289 kB     00:00
RPM Fusion for Fedora 27 - Free                        4.1 MB/s | 717 kB     00:00
RPM Fusion for Fedora 27 - Nonfree - Updates           726 kB/s |  27 kB     00:00
RPM Fusion for Fedora 27 - Nonfree                     1.8 MB/s | 163 kB     00:00
Last metadata expiration check: 0:00:00 ago on Sat 17 Feb 2018 01:51:32 PM EST.
======================== Name & Summary Matched: vlc =============================
npapi-vlc.x86_64 : NPAPI plugin for libvlc
phonon-backend-vlc.x86_64 : VLC phonon backend
libvlcpp-devel.noarch : Development files for libvlcpp
phonon-qt5-backend-vlc.x86_64 : Vlc phonon-qt5 backend
python2-vlc.noarch : VLC Media Player binding for Python
python3-vlc.noarch : VLC Media Player binding for Python
npapi-vlc-gtk.x86_64 : NPAPI plugin for libvlc - gtk version
npapi-vlc-filesystem.x86_64 : NPAPI plugin for libvlc - filesystem

I've had to install it manually by downloading the RPMs directly from the website. Why wouldn't dnf be able to find vlc?

# dnf install vlc
Last metadata expiration check: 0:05:17 ago on Sat 17 Feb 2018 01:51:32 PM EST.
No match for argument: vlc
Error: Unable to find a match
click to hide/show revision 2
retagged

Installing VLC from rpmfusion fails with "not found"

Hi, I'm using fedora27 and have the rpmfusion repos installed:

$ ls -l *rpmfusion*
-rw-r--r-- 1 root root 1248 Nov 13 13:17 rpmfusion-free.repo
-rw-r--r-- 1 root root 1245 Nov 13 13:17 rpmfusion-free-updates.repo
-rw-r--r-- 1 root root 1305 Nov 13 13:17 rpmfusion-free-updates-testing.repo
-rw-r--r-- 1 root root 1293 Nov 13 13:21 rpmfusion-nonfree.repo
-rw-r--r-- 1 root root 1290 Nov 13 13:21 rpmfusion-nonfree-updates.repo
-rw-r--r-- 1 root root 1350 Nov 13 13:21 rpmfusion-nonfree-updates-testing.repo

However, installing or even searching for vlc fails:

# dnf search vlc
Fedora 27 - x86_64 - Updates                           7.0 MB/s |  19 MB     00:02
Fedora 27 - x86_64                                     6.8 MB/s |  58 MB     00:08
RPM Fusion for Fedora 27 - Free - Updates              2.8 MB/s | 289 kB     00:00
RPM Fusion for Fedora 27 - Free                        4.1 MB/s | 717 kB     00:00
RPM Fusion for Fedora 27 - Nonfree - Updates           726 kB/s |  27 kB     00:00
RPM Fusion for Fedora 27 - Nonfree                     1.8 MB/s | 163 kB     00:00
Last metadata expiration check: 0:00:00 ago on Sat 17 Feb 2018 01:51:32 PM EST.
======================== Name & Summary Matched: vlc =============================
npapi-vlc.x86_64 : NPAPI plugin for libvlc
phonon-backend-vlc.x86_64 : VLC phonon backend
libvlcpp-devel.noarch : Development files for libvlcpp
phonon-qt5-backend-vlc.x86_64 : Vlc phonon-qt5 backend
python2-vlc.noarch : VLC Media Player binding for Python
python3-vlc.noarch : VLC Media Player binding for Python
npapi-vlc-gtk.x86_64 : NPAPI plugin for libvlc - gtk version
npapi-vlc-filesystem.x86_64 : NPAPI plugin for libvlc - filesystem

I've had to install it manually by downloading the RPMs directly from the website. Why wouldn't dnf be able to find vlc?

# dnf install vlc
Last metadata expiration check: 0:05:17 ago on Sat 17 Feb 2018 01:51:32 PM EST.
No match for argument: vlc
Error: Unable to find a match