Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 27 freezing with Nvidia proprietary drivers

Hi,

I’m trying to replace Windows with Fedora and am unsuccessful.

The initial installation works fine, it’s after I install the Nvidia proprietary drivers that I run into problems. Fedora will either freeze at the login screen or shortly after logging in.

I have attempted multiple reinstalls with installing the Nvidia drivers first to ensure that this is the cause of the problem.

I have tried

  • Following the steps on if not true then false
  • Installing drivers from RPMfusion
  • Installing drivers from negativo17

My system specs are

  • Intel i7 6700k
  • Asus VIII Hero Alpha
  • Asus Geforce 1080 O8G

I’ve been trying to find a solution to my problem and some say to change the DE. However, I really like using gnome and it’s layout. Also, other solutions say to stick to the nouveau drivers. As much as I would like to use the open source drivers, it doesn’t give me quite the performance I need.

Has anyone also encountered this problem? Is there any solution to this issue?