Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Bluetooth connection issues on F27

I have a bluetooth headset that I've been using for a few months with my computer and my phone, but now it doesn't seem to be working on my PC (Thinkpad laptop). I'm running Fedora, and I stopped using it for a while after I switched to F27 (I got a better pair of headphones but my dogs chewed them up...), but other than that I don't think I've changed anything on my PC. The headphones connect to my phone no issue, but my PC won't connect to my phone or the headset.

Right when I start/reboot, I'll be able to connect to the headset (I have to delete the previous profile and re-search for it every time), but that connection lasts <5 minutes before suddenly disconnecting, and after that I'm not able to see it in any scans or anything.

I've tried all the guides I could find using bluetoothctl to no avail.

When I run hcitool dev and hciconfig, they return what I assume is my bluetooth adapter, and when I run sudo service bluetooth status, it says it's loaded, active, and running, and the log it prints out lists no errors starting it up (and I get similar results when I restart it).

All the tools I'm using are as up-to-date as DNF will let me update them. Graphically, I'm using BlueDevil (KDE's default bluetooth manager), but I've tried with BlueMan to similar results.

Not really sure where to go from here, any advice?