Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem with wifi after recent update to kernel 4.10.11 fc25

Hello, I am using fedora 25 with recent kernel 4.10 after the recent update to kernel 4.10.11-200 theres a problem with wifi wifi is not recognizing my network, even accessing through hidden network also failed to recognize the network. at startup the wifi seemed to be operational and connected to my network but within 4-5 seconds an error of "failed to activate the connection" pops up and wifi stops recognizing my network.

I tried installing brodcom-wl along with its kmod and also broadcom-wl-dkms in both approaches no solution, moreover now my LAN is also having the same problem.

wifi works perfectly fine on earlier kernels of 4.10

Please let me know how to fix this. if its a kernel issue I hope that it will be fixed in the next updates.

Problem with wifi after recent update to kernel 4.10.11 fc25

Hello, I am using fedora 25 with recent kernel 4.10 after the recent update to kernel 4.10.11-200 theres a problem with wifi wifi is not recognizing my network, even accessing through hidden network also failed to recognize the network. at startup the wifi seemed to be operational and connected to my network but within 4-5 seconds an error of "failed to activate the connection" pops up and wifi stops recognizing my network.

I tried installing brodcom-wl along with its kmod and also broadcom-wl-dkms in both approaches no solution, moreover now my LAN is also having the same problem.am using rtl8821ae PCI wireless card.

wifi works perfectly fine on earlier kernels of 4.10

Please let me know how to fix this. if its a kernel issue I hope that it will be fixed in the next updates.

Problem with wifi after recent update to kernel 4.10.11 fc25

Hello, I am using fedora 25 with recent kernel 4.10 after the recent update to kernel 4.10.11-200 theres a problem with wifi wifi is not recognizing my network, even accessing through hidden network also failed to recognize the network. at startup the wifi seemed to be operational and connected to my network but within 4-5 seconds an error of "failed to activate the connection" pops up and wifi stops recognizing my network.

I am using rtl8821ae PCI wireless card.

wifi works perfectly fine on earlier kernels of 4.10

lspci -vv -s 02:00.0 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter (rev ff) (prog-if ff) !!! Unknown header type 7f Kernel driver in use: rtl8821ae Kernel modules: rtl8821ae

modinfo rtl8821ae filename: /lib/modules/4.10.12-200.fc25.x86_64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/rtl8821ae.ko.xz firmware: rtlwifi/rtl8821aefw.bin description: Realtek 8821ae 802.11ac PCI wireless license: GPL author: Realtek WlanFAE wlanfae@realtek.com alias: pci:v000010ECd00008821svsdbcsci* alias: pci:v000010ECd00008812svsdbcsci* depends: rtlwifi,rtl_pci,btcoexist,mac80211 intree: Y vermagic: 4.10.12-200.fc25.x86_64 SMP mod_unload signat: PKCS#7 signer: sig_key: sig_hashalgo: md4 parm: swenc:Set to 1 for software crypto (default 0) (bool) parm: ips:Set to 0 to not use link power save (default 1) (bool) parm: swlps:Set to 1 to use SW control power save (default 0) (bool) parm: fwlps:Set to 1 to use FW control power save (default 1) (bool) parm: msi:Set to 1 to use MSI interrupts mode (default 1) (bool) parm: debug:Set debug level (0-5) (default 0) (int) parm: disable_watchdog:Set to 1 to disable the watchdog (default 0) (bool) parm: int_clear:Set to 0 to disable interrupt clear before set (default 1) (bool)

iwconfig wlp2s0 IEEE 802.11 ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off

virbr0 no wireless extensions.

enp1s0 no wireless extensions.

lo no wireless extensions.

virbr0-nic no wireless extensions.

Please let me know how to fix this. if its a kernel issue I hope that it will be fixed in the next updates.