Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No governors found AMD FX-6300

Here is the output of sudo cpupower -c all frequency-info

analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  CPUs which run at the same hardware frequency: Not Available
  CPUs which need to have their frequency coordinated by software: Not Available
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: Not Available
  available cpufreq governors: Not Available
  Unable to determine current policy
  current CPU frequency: Unable to call hardware
  current CPU frequency:  Unable to call to kernel
  boost state support:
    Supported: yes
    Active: yes
    Boost States: 2
    Total States: 7
    Pstate-Pb0: 4100MHz (boost state)
    Pstate-Pb1: 3800MHz (boost state)
    Pstate-P0:  3500MHz
    Pstate-P1:  3000MHz
    Pstate-P2:  2500MHz
    Pstate-P3:  2000MHz
    Pstate-P4:  1400MHz

shows the same, on all cores, googled myself to death to see what needs to be done, tried different solutions, bios changes, modprobeing different acpi and amd stuff, all to no avail. I would love to talk to others with the same processor, to see if the problem is Fedora, or AMD. Has anyone got this to work? If so, please be so kind as to tell me how.

No governors found AMD FX-6300

Here is the output of sudo cpupower -c all frequency-info

analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  CPUs which run at the same hardware frequency: Not Available
  CPUs which need to have their frequency coordinated by software: Not Available
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: Not Available
  available cpufreq governors: Not Available
  Unable to determine current policy
  current CPU frequency: Unable to call hardware
  current CPU frequency:  Unable to call to kernel
  boost state support:
    Supported: yes
    Active: yes
    Boost States: 2
    Total States: 7
    Pstate-Pb0: 4100MHz (boost state)
    Pstate-Pb1: 3800MHz (boost state)
    Pstate-P0:  3500MHz
    Pstate-P1:  3000MHz
    Pstate-P2:  2500MHz
    Pstate-P3:  2000MHz
    Pstate-P4:  1400MHz

shows the same, on all cores, googled myself to death to see what needs to be done, tried different solutions, bios changes, modprobeing different acpi and amd stuff, all to no avail. I would love to talk to others with the same processor, to see if the problem is Fedora, or AMD. Has anyone got this to work? If so, please be so kind as to tell me how.

UPDATE:Enabled cool n quiet in bios, and it allows me to set the governors and frequency.