Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't automount NTFS drive in Fedora 25

Hello, I migrated from Windows to Fedora and one of my Data drives is NTFS. I want to automount it at startup, but unfortunately it doesn't work.

I tried to edit the /etc/fstab , but every time I add the drive on fstab it goes to emergency mode after reboot. Here's how my /etc/fstab looks like (I commented out the line so it doesn't crash the system):

#
# /etc/fstab
# Created by anaconda on Sat Apr  1 17:16:06 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1
UUID=287aa136-2d41-40e3-bb84-780cc2b0de65 /boot                   ext4    defaults        1 2
/dev/mapper/fedora-home /home                   ext4    defaults        1 2
/dev/mapper/fedora-swap swap                    swap    defaults        0 0

# NTFS formatted storage disk
#UUID=1A022B4B022B2AE9   /mnt/Data    ntfs defaults    0 2

When I mount it manually from Fedora it mounts at /run/media/user/Data so I tried using this location in the fstab as well but it went to emergency mode again.

I also tried the "Drives" utility but it inserted a line in fstab that didn't result in anything.

Here is my blkid:

/dev/sda1: UUID="287aa136-2d41-40e3-bb84-780cc2b0de65" TYPE="ext4" PARTUUID="466f129c-01"                                                                                                                      
/dev/sda2: UUID="UEjJHS-5HGQ-5DJK-LRVz-oxuc-OvJt-gjag1N" TYPE="LVM2_member" PARTUUID="466f129c-02"                                                                                                             
/dev/sdb1: PARTLABEL="Microsoft reserved partition" PARTUUID="39f9ebf3-5631-41ba-ab84-e7f235084001"                                                                                                            
/dev/sdb2: LABEL="Data" UUID="1A022B4B022B2AE9" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="87719cda-2b46-4feb-8d47-c4f4c7771d8a"                                                                   
/dev/mapper/fedora-root: UUID="043c12fe-0837-4f9a-9e2c-72d67303834c" TYPE="ext4"                                                                                                                               
/dev/mapper/fedora-swap: UUID="943f78b7-e57b-4b5c-b24f-11bfdc130078" TYPE="swap"                                                                                                                               
/dev/mapper/fedora-home: UUID="816b5c24-d2de-4d2f-a09f-cd90544d8998" TYPE="ext4"

And here is my mount -l

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime,seclabel)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,seclabel,size=8201852k,nr_inodes=2050463,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,seclabel)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,seclabel,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,seclabel,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime,seclabel)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mapper/fedora-root on / type ext4 (rw,relatime,seclabel,data=ordered)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime,seclabel)
mqueue on /dev/mqueue type mqueue (rw,relatime,seclabel)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,seclabel)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=41,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=14216)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,seclabel)
/dev/sda1 on /boot type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/fedora-home on /home type ext4 (rw,relatime,seclabel,data=ordered)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
tmpfs on /run/user/42 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=1642956k,mode=700,uid=42,gid=42)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=1642956k,mode=700,uid=1000,gid=1000)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/fuse on /root/.cache/doc type fuse (rw,nosuid,nodev,relatime,user_id=0,group_id=0)
/dev/sdb2 on /run/media/user/Data type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2) [Data]

I did the same thing on my debian system and it worked. So strange. Any help will be appreciated. Thanks in advance!